Negative.lua:223: attempt to index local 'i' (a nil value)

Hi @JerryB and @StephenK,

Try the instructions in this link and let me know if that helps:

Also, check the filename of the image you are trying to convert and ensure that are no symbols in the filename (in other words, the filename should be comprised of just numbers and letters). This specific filename issue should be resolved with v2.1, but in the meantime, if you encounter this, you can test by renaming the file and trying to convert again.

-Nate

Hi @Nate,

I tried the instructions at the link and uninstalling, moving, and reinstalling NLP in a location on the C Drive with universal write privileges does not solve the problem. I still get the exact same error message. The problem occurs on every image file that I try and there are no symbols in any of my file names unless you consider an underscore an symbol. In any event, I also tried removing the underscore and still got the same error message.

Hmm…

ok, could you possible link to a file giving you trouble? (Or if you don’t want to link, you can email me personally at nate@natephotographic.com)

Also, could you try installing in the ROOT of your C:\ drive? There is some weirdness with folder permissions in Windows, and I just want to rule that out.

Do you have Lightroom installed on a networked drive by chance?

I’m also interested if anyone found that NLP v2.0 worked ok with Lightroom 8.3 but are noticing problems starting now with Lightroom 8.4?

Interesting. I first installed your plugin in a subdirectory of “C:\program Files” that I successfully use for some of my other LR plugins (didn’t work) and, after your first message, I installed the plugin in a subdirectory of the folder of my C Drive that LR uses for installed plugins, “C:\Users\GB\AppData\Roaming\Adobe\Lightroom\Modules” (also didn’t work). After your last message, I created a NegativeLabPro folder at the root of my C Drive and installed a copy of your plugin in this folder and it now works. The problem has to be some sort of weirdness with folder permissions in Windows and what your plugin requires. I can understand a potential issue with its location in “C:\Program Files” but I have no clue why it wouldn’t run in my user/AppData/Roaming folder since those folders are specifically designed for storing program data. In any event, my problem is resolved. Thank your for your help. FYI, I stop my trial assessment and purchased the plugin.

Yep same problem. Downloaded the trial version, followed the advice above and below, still getting the lua.223 error every time. The plugin folder is in a NegativeLabPro folder placed in my C: root directory as mentioned by @JerryB. Tried renaming the file too, no luck. Tried placing it elsewhere. Tried renaming the photo file. Can’t seem to get it to work. Running Lightroom 6 on Win10.

Thanks Nate - creating a separate directory for the plugin in the root directory of C worked. It’s strange that I didn’t need to do this on my desktop and it worked fine? Perhaps a difference in permissions that I’m not aware of?

Suggestion to move the plugin folder outside of the protected Program Files/Adobe/Adobe Lightroom Classic/ location worked. I compared the permissions on the plugin folder when under Program Files and outside and the difference appears to be in the Authenticated Users entry with rwx permissions which is missing when the plugin is placed under Program Files. Adding this permission to the plugin folder makes it work even when placed under Program Files/Adobe/Adobe Lightroom Classic/.

Another approach that worked for me is placing the plugin under C:\Users\<UserName>\AppData\Roaming\Adobe\Lightroom\Modules (as suggested also at Adobe Forums). Note that in my case the Modules folder was missing and had to be created manually. After that though Lightroom has automatically found the plugin and it worked without errors.

There is still one other concern. Since my plugin was not registered yet on Windows, I tried to do that but the registration was not saved and the plugin was still in trial mode on the next Lightroom start. It only succeeded when starting Lightroom with Administrator priviledges and registering. It worked well with regular starts afterwards. This might be a part of the same permissions issue which this topic is about.

The only reason I don’t broadly recommend this is that I don’t believe this will work if you are saving your presets with your lightroom catalog (rather than the default location). So for about 10% of users, it won’t work as expected.

Good to know. I’m not really sure why this is only needed in some situations. I haven’t been able to replicate the permissions issue on my own Windows machine, no matter where I put it. Oh well, the ways of Windows are sometimes mysterious. :slight_smile:

Hello, I tried your suggestions above, i.e the AppData\Roaming etc. path. No luck so far.

I noticed that once it’s placed in that path you can no longer remove it through Lightroom, the Plugin Manager “Remove” button being greyed out. As for why it doesn’t work, I’m guessing it’s most certainly folder permission related as I get the lua:223 error on any photo, RAW, jpeg etc.

I’ve tried moving it to other folders, restarted Windows. I haven’t reinstalled Lightroom 6 yet though that will probably be the next step. I’ll keep the forum posted.

Try this:

1) In Windows file explorer, navigate to where you have placed the NegativeLabPro.lrplugin folder that you are using in Lightroom. Right click on that folder.

2. Select "Properties"

3. In the properties dialog, move to the “Security” tab. Select “Authenticated Users”, then click "Edit"

4. To the right of “Full Control” hit “Allow”. Then click "OK"

5. Restart Lightroom (if it is open) and try again.

Hi Nate, I tried your solutions, no luck. I’ll continue tinkering. But thanks for the quick reply!

Hmm… :thinking:

And you’re sure that the file names do not contain any symbols?

You’re sure that the files you are trying to convert are available and not just previews? (For instance, if the original files are on an external hard drive that is not currently connected, that would cause an issue)

The only other thing I could think of is perhaps you have an anti-virus program that is not allowing it to run…

Yes, I thought of that too. My Anti-Virus is disabled, no luck on that front.

As for the file name, I DSLR scanned a picture yesterday, named it “Test”. As its Olympus raw format the file extension is .ORF
Unless its the file format that’s throwing NLP off, though I’ve tried a bunch of JPEG’s and same story.
I’m sure there’s a real simple answer to this :thinking:

As for the the file location, the “Test.ORF” file is on my desktop. I tried putting it on D: drive, same story.

Hmm…

Could you go to “help > system info” in Lightroom and copy/paste that info and PM to me?

Another thing you might try is going into the folder " NegativeLabPro.lrplugin/win" and double clicking “convert.exe” to see if anything on your system prevents that from running…

Convert.exe functions, as in a DOS script style window pops up, runs through and closes.

Well, I’ve tried the various suggestions, I even downloaded the sample RAW files on the Download page. Nothing doing. I’m almost positive its something that’s blocking the NLP plugin from correctly launching. Trouble is, what? :face_with_monocle:

Just want to say that im gettign this issue too. Trying the trial version and was really hoping to buy this but its not working for me. I’ve tried all the suggestions in this thread and I get the same error message.

:frowning:

So… It now works. I have no, seriously, zero idea why. :crazy_face:

The only thing I have changed recently is I downloaded the latest Nvidia driver, though I do this regularly so it’s not as if the card was using a prehistoric driver.

I’m going to not touch anything settings-wise, try the demo for a week or so then buy it, if it still works. As far as I’m concerned it’s voodoo.

Thanks to Nate and the other posters for their solutions!

after reading your update, i tried updating the driver for my GTX 1070 to the September 10th 2019 latest driver. it didn’t work for me :frowning: