Using NLP with a version earlier than Lightroom Classic v9.0

Step 9 of the installation instructions for NLP on Windows says:

“If you are using a version earlier than Lightroom Classic v9.0, make sure to TURN OFF the “Use Graphics Processor” option in Lightroom. To do this, go to “Preferences > Performance” and un-check the “Use Graphics Processor” option. If you are using Lightroom Classic v9.0 or later, you can leave graphics processing on.”

However, no explanation is provided. I am running Lightroom 6.14 and have had the “Use Graphics Processor” option turned on since I first installed it. Much later on, I purchased NLP and having been running NLP without any apparent problems. Can anybody explain the basis of the instruction to turn the “Use Graphics Processor” option off?

EDIT: I think that I have now figured things out. The phrase " Lightroom Classic v9.0" actually means exactly what it says. Lightroom 6.14 is not a version of Lightroom Classic and the advice to turn off “Use Graphics Processor” does not apply to Lightroom 6.14. This issue is better explained in the troubleshooting guide The settings in Negative Lab Pro aren’t updating the image.

Right, basically there was a bug in the SDK prior to v9 that prevented the image from updating in certain circumstances… for instance, changes made via a dropdown menu (like the “tones” settings) would not be reflected in the image until the user changed another setting. It may vary based on your system and graphics card, but in general, it was just safer to not use graphics acceleration in earlier versions of Lightroom (and at least in my own testing, the earlier versions of Lightroom were sometimes slower with graphics acceleration enabled).

One of the major improvements in the newer versions of Lightroom Classic is that the graphics acceleration significantly improves speed of conversion and editing, and Adobe fixed the bug in the SDK so now all changes (including those done via a dropdown menu) are immediately and properly reflected in the preview.

Hope that helps!
-nate

Hi Nate,

Many thanks for your input on this issue. I have done some additional testing and find that having the graphics acceleration on is not harming the performance of NLP. I have also found that it speeds up Lr 6.14 in general, so have decided to leave it on.

Now, do you know anything about adjusting “Frame offset” in VueScan when scanning film strips? I cannot get my head around that issue at all, and I have lots of questions :grinning:

Cheers,
Raymond

1 Like

Here’s what the Vuescan manual has to say about it:

FRAME OFFSET:
This option sets an offset for the start of the each frame on a film strip on the Nikon LS-30, LS-40, LS-2000, LS-4000, LS-8000, LS-9000 scanners, the Canon FS4000 when the strip film adapter is used, and the SprintScan 120 when the Medium Format adapter is used.
Use this option if there is some leader on the film strip, or if you’re scanning panoramic frames and need to scan what would otherwise be the gap between 35mm frames. This option can be either a positive or negative number.
The units for this option are normally millimeters, but this can be changed with the Prefs | Crop units option.

In principle, setting the frame offset ought to be easy. I have a copy of Sacha Steinhoff’s book “The VueScan Bible” and that says much the same the VueScan Manual.

While experimenting with the alignment issues, I have tried adjusting the “Frame offset:” value on the “Input” tab. On the “Prefs” tab, I have the units set to “mm” for the “Crop units:” and for the “Printed units:”. The default value is 0 (zero) and clicking the up-arrow once changes 0 to 1.104. I imagined that clicking the down-arrow once would return value to 0, but it changes it to 0.307 and clicking it a second time changes it to -0.489. This is counter-intuitive.

I have no idea what the units are and using the up and down arrows yields unexpected results. In addition, if I try to manually edit the offset value, VueScan often changes what I have typed to another value that is close, but not identical. I guessed that the offset values might be handled internally in inches, but converted to mm for display, but that does not seem to be the case as far as I can figure.

I have even seen VueScan inserting random numbers into the “Frame offset” value field while I’m trying to insert a value from the keyboard.

My brain is beginning to hurt.

The ways of Vuescan are indeed mysterious.

Have you tried contacting their support team? It may just be a bug?

I have indeed contacted the VueScan support team, but I suspect that the team comprises just Ed Hamrick. I have tried to explain the issue to him but received a somewhat cryptic response that said just: “Yes, type a number into this field and press the “Preview” button again.” which did not help me at all. There is no official VueScan forum to allow discussion with other users, so that’s a bit of a barrier to making progress.

I plan to make a video recording (using Flashback) of the bizarre behaviour of VueScan and send it to Ed in the hope that he might then better understand the problem.

Many thanks for your continued interest in this issue.