Impossible to get a download link

Hello all.

I am trying to get a download link from but nothing happens when I fill the form.

I tried multiple email addresses and multiple web browser, but with the same result. When I hit the “Send download link” button, a red square appears above the form and nothing happens.

Do you have an idea why ?


Hmm, weird. Do you have everything filled out? Just tried and seems to still be working.

Can I ask what operating system and browsers you have tried?

You can also go directly to the download page here (skipping the form):

The only issue is that you won’t receive updates if it hasn’t been able to confirm your email…


Thanks for the answer.
I filled everything yes.
I tried several things that didn’t worked out:

  • Changed browser (I am curently with Chrome Version 78.0.3904.108, I tried Edge too, windows 10)
  • Changed my network using my Android phone and my wife’s Iphone using no wifi.
  • Deactivating Adblock (you never know)

I am from France, maybe there is something to do with that ?

Is there a way to get the updates even if I install the plugin from your link ?

For info, it finally worked today.
After trying everyday since last week. Hurray !