NLP broken after update to Big Sur (and workaround)

I’ve updated a clone of my prod drive to Big Sur and tried to run NLP on it.

NLP launches as expected, but then, after pressing convert, a series of error messages came up.

First distinct message:

I had to press cancel a few times before the next message came up:

Then, after pressing OK, this message appeared:
Bildschirmfoto 2020-11-13 um 19.06.53

Please note that NLP ran without issues before updating. Loading the plug-in from a different location did not help, which is clear according to below. Clone (CCC) with Big Sur running on an external SSD.

WORKAROUND: I went into the plug-in and launched the terminal objects with a right-click and ack’ed/saved the respective messages/rights and after that, NLP ran as expected. Somehow, not all of the highlighted objects are accepted by macOS Big Sur:

For the geeks around here: the folder “previews” contains tiffs of the images of (the latest?) conversion, therefore, the size of the plug-in can change considerably…

When did you download the installer package? The latest installer package is notarized following Apple’s guidelines (and I also had to notarize the underlying image tools and libraries that you have highlighted). So if you ran the installer itself, you shouldn’t be getting that first error message.

If you install everything custom, then you may need to open up “preferences > security & privacy” to allow the underlying packages to run as intended when you receive that first message.



According to the first message (and the date of the zip file I kept), it was September 30th.

Ok - the package that was notarized by Apple wasn’t up until Oct 2. Try downloading again (use the same link you received before via email, which just takes you to the latest download page). Then run that installer. The NegativeLabPro.lrplugin file that is produced from running that installer should not have that first error.

Tested again and got the same error messages using the following environment and procedure:

Internal drive (A) is on Mojave, has two user accounts.

  • User 1 has NLP 2.2.0, downloaded and installed September 30th
  • User 2 has NLP 2.2.0, downloaded and installed November 13th
  • NLP works as expected with both users on drive (A)

Cloned (A) to an external SSD (B) with the current version of Carbon Copy Cloner.
Updated (B) to macOS Big Sur using a bootable installer made from the Big Sur Installer app.

External drive (B) is now on Big Sur and still has the two user accounts

  • Both user accounts still have the same two versions of NLP as above
  • Both user accounts produce the error messages when NLP starts the conversion.


  • Big Sur removes the permission to run the plug-in
  • After an upgrade to Big Sur, NLP must be re-installed or fixed as mentioned way up.
  • Both installations bear the 2.2.0 version although the more recent download
    has different contents (notarization and newer mac objects)

I’m always up for a bug hunt, but I couldn’t reproduce this one. I’m on Big Sur 11.0.1 and NLP 2.2.0 — NLP worked normally on the first try and behaves just as it did before the OS update.

My update procedure was less sophisticated than the OP’s… I was updating from the immediately previous version (Catalina) and I simply downloaded and ran the Big Sur installer, rather than cloning a volume and making a bootable installer disk, so it’s possible that I started out with a permissions environment that needed simpler fixes than his did. Anyway, it seems that this problem is not one that everyone will experience…l

Awesome to hear! Yes, the majority of users with standard installations seem to be having no issues with the Big Sur update, but I still have heard some bug reports in addition to what @Digitizer has noted. So this definitely isn’t the only report i’ve seen of Big Sur causing some issues…

My current theory is, that the step from Mojave to Big Sur might be the source of the issue - or not.
UPDATE: Did the same routine with Catalina with the same result. Had to authorize again.

If (and when) I update to Big Sur, it will most probably be through a clean install. NLP will be one of the smallest issues compared to Mail and Keychain migration. Although I use iCloud, a few things like intelligent mailboxes and secure notes can be lost in the process.

It must be something very specific to your environment or MacOS X installation. Last week I upgraded my Catalina to Big Sur (11.0.1) without a shadow of problems. Also, my NLP (most recent release - 2.2) with LrC 10.0 (CR 13.0) runs in a very smooth way.