Adobe Lightroom 9.3 and Negative Lab Pro

Adobe just released a new version of Lightroom (version 9.3) with a new rounded app icon
ready for the upcoming macOS 11 Big Sur.

NLP seems to work under this new version too - as far as I can see from my first tests.

@nate, can you already say more about interoperability with the new version?

1 Like

I am seeing some color photos that had been converted turn into BW images. Not investigated deeply yet.

Everything seems to be working great. I really like the updates Adobe made here. I’m not aware of any issues yet, but if you run across any, please let me know with as much detail as possible!


1 Like

Noticing the following with NLP 2.1.2 and LR 9.3 (Camera RAW 12.3):
When you hit “convert negatives”, NLP 2.1.2 shortly shows the conversion progress bar and then comes up with the Edit screen, but nothing seems to have been converted: the picture still is showing as the negative in the Lightroom editing window.
You manually have to change the dropdown menu “Tones” from its default setting “Standard” to any other preset (and then eventually back to “Standard” if you need to), only then the conversion takes place (or at least, the preview is changed to reflect the conversion).
And: in the TIF copy creation, the “stack with…” option does not work. I cannot see the newly created TIF being stacked or at least being imported into the library. I have to manually synchronize the current folder in Lightroom, so the new TIF copy is imported…
Maybe, it’s my Mac Mini 2018, or the combination with an eGPU, or just Lightroom itself - I can’t tell.
Just wanted to let you know.
UPDATE: this only seems to happen with the Mac Mini 2018 - my MacBook Pro Retina late 2013 does not have this issue. Same OS X version (Mojave), same Lightroom version, working off the same catalogue (*.lrcat is synchronised between the two computers), same NLP version. All is the same but the computer.

1 Like

I suspect this is an issue with eGPU. I’d be interested to know if you turned off “Graphics Acceleration” (in Lightroom > Preferences > Performance) if this began working again as it should.

I suspect it is working, but you need to be viewing the folder itself in Lightroom to be able to access the stacked copy. So for instance, if you are in the “Recently Imported” view, or a Collections view, you will not be able to see the stacked copy (just the way that Lightroom works). You can quickly get to the folder view in Lightroom by “right-clicking” the image, and selecting “Go to folder in Library”.

UPDATE: Never mind, I just re-downloaded and re-installed the plugin, which re-created the shortcut as well.

I’m not sure when this happened relative to the Lightroom update cycle, but today when I tried to import some digitized negatives I found that all my third-party plug-ins (including NLP) had been disabled. I re-enabled NLP by entering my license code, and now it works, but the MacOS keyboard shortcut (^N) does NOT work. Any notions as to what, if anything, can be done? I checked the shortcuts in the Keyboard control panel and did not find anything that conflicts with this one.

1 Like

Nate, thanks for answering!
Unfortunately, this does not help. With Graphics Acceleleration deactivated, it still shows the abovementioned behaviour.
Same goes for the stacking issue - it happens, even when I am IN the appropriate library-folder.
So right now, both these issues seem tied to the new Mac Mini. As I mentioned: it is on exactly the same software versions (OS, software etc.) as my MacBook Pro Retina Late 2013… Strange, huh?

1 Like

I’ve had a similar experience in earlier versions of Lightroom. Images would only update upon some change in the NLP gui.

As of version 9.3, Adobe changed how images update: Filmstrip and the preview (up left) don’t update synchronously to the main preview. I’ll try to see what this does when I use NLP…