NLP does not start with selected multiple images and after

When I select multiple photos and start NLP to convert, it won’t start. After trying that, also with a single image NLP won’t start anymore. It only shows the ‘loading NLP’ window in a flash OR the notification “NLP-2.3-Frontier-S5 updated for x images”. Most of the time NLP will start again after restart of LR.
BTW, this is also the case when I select already converted images for Roll Analysis.
Looking forward for a solution to be able to use roll analysis.Thanks


Can you let me know if you have multiple monitors in your setup?

It looks like for some reason, with multiple monitors, that the NLP box may load in your unused monitor when multiple images are selected. I’m not sure why this is, exactly, but I’m looking into it.


Hi Nate,
I now tried it with and without 2nd monitor attached and I couldn’t replicate the error at first (NLP started with a batch selected). At some point though, the error returned, but my second monitor was not attached. After restart LR I tried with another roll and I was able to batch edit with a second monitor attached and on. Then I reselected those (converted) images and tried to start NLP, but it didn’t come up again, only the notification“NLP-2.3-Frontier-S5 updated for x images” (or similar). Thanks for looking into this.

Ok, thanks @mennodv

It’s hard for me to replicate this because I don’t have a second monitor…

But under the hood, Lightroom remembers where you last had the NLP window placed, and will try to open it up there again. So for instance, if you the NLP window placed in a second monitor, it will try to open up the NLP window in the second monitor in the future.

The only thing that has changed in this respect with v3 is that there is now an additional window that opens first to let you know that everything is loading (so there isn’t as much delay between invoking NLP and getting visual confirmation that it is starting up). It could be that this additional loading window is somehow causing an issue when combined with second monitors.

I can try sending you a version that does not have this initial loading screen to see if that fixes it. Or a version that doesn’t try to remember the window frame position, but of course this would also be annoying.

I’m curious though if you move the NLP window frame to be within your main monitor, and keep it there with the second monitor unattached, if this issue remains.

Hi Nate,
I really don’t think it has to do with a second monitor as it also happens without it attached as mentioned. So regarding your last line, that is done and proven to not work, unfortunately. I just gave it another try and confirmed.
It does seem to have to do with the number of images selected. Below 21 it seems fine and somewhere above it won’t work (and consecutively also won’t work with 1 image selected until restart). It could be coincidence…(?)

Hi Nate: I’ve written about this issue a couple of weeks ago. I have a single monitor. Sometimes NLP works as expected, other times I just see the “loading” screen without NLP starting. Restarting LR takes care of the problem, at least for awhile.


I’m also having the same issue. I can’t even do roll analysis but it will not open the NLP window. Sometimes it will work if I reload the plugin or close and restart Lightroom, but not always. Sometimes it will then open the window but after converting it closes so I can’t make any adjustments (it also then doesn’t convert the negatives).

Is there maybe another cache to try clearing somewhere? Due the size of the images and conversions I don’t know if it’s maybe a memory issue or not. I’ve got not clue on next steps unfortunately.

At this moment the plugin is almost completely unusable :broken_heart: