V3 Issues & Fixes Thread

Thank you for your reply, Nate.
After the reset, the problem doesn’t appear to be resolved, in my case. My old version of NLP disappeared, however.

Thanks, Nate-
Negative Lab Pro v3 is still in Plugin Extras after resetting the preferences (via Alt-Shift plus start Lightroom).
Again, to reiterate. Right now v2.4.2 has been removed.


Yep, that is to be expected after resetting preferences… you would need to add it back in plugin extras.

And I’m gathering that v3 is still not working after resetting preferences?

I’m trying over here to set up a system with Windows 11 and Lr 6.14 to see if I can figure out why this isn’t working for you.


Quick update: I’ve been able to set up a partition with Windows 11 running LR 6.14 and replicate the issue with it not loading as it should. Should have a fix tomorrow.


UPDATE: Fixed as of v3.0.2

Will this also fix the issue on macOS?

I’m having the same problem. NLP window flashes for a split second and then - nothing.

macOS 13.5
Lightroom Classic 12.4, upgraded from NLP2
mac Mini with M2 Pro

Doesn’t matter which photo I try, NLP works once after installation and then stops.

1 Like

Hi Nate,

MacOS Big Sur / Version 11.6.2
LightRoom 12.4

Is it normal that i have always NLP v2.3 after installing NLP 3.0 ?



1 Like

Yes, that is how it should be. The version of the raw color profile is still v2.3. This does not change with each version. I only update it if I’ve found ways to improve.

1 Like

Yes, should be fixed as of v3.0.2.

If for some reason, you still experience issues, and restarting Lightroom doesn’t help, there could be something funky with your Lightroom preferences. I would recommend trying to reset your Lightroom preferences. You might need to re-add Negative Lab Pro to your plugin manager after doing this.

Hi Nate! i Buy V3 on November 27, 2022 and a have a license key, but not working… its not possible activate…

I’m having some issues with adjustments when using anything other than “Pro Lab” mode in the Roll Process dropdown. Color temperatures will vary wildly between images, and the color temperature controls will sometimes be entirely reversed – cooler making the image more yellow, warmer making it more blue.

It’s a shame because I really like “Basic Lab” as a starting point and find “Pro Lab” to often create overly contrasty images that don’t feel natural in the context of the whole roll when it encounters darker or underexposed images.


You need to use the license key I sent you in the email with the subject “Negative Lab Pro v3.0 is here!” on August 2nd, 2023. It will be different than the previous key you received because I had to switch payment providers.

If you were a part of the pre-purchase and did not receive that email, you can also go to My Orders - Lemon Squeezy and enter the same email you used during purchase and it will email you a “magic link” to see your license and order details.

Hmm, there should be zero difference between the color temperature of “Pro Lab” and “Basic Lab” - the only difference be the dynamic range. There will be color differences between “Pro Lab” and “Darkroom Print” because they are using different color algorithms. But even in that case, it shouldn’t change the way that controls are working.

Would it be possible for you to send a video to me at nate@natephotographic.com, showing this happening? Also, can you try restarting Lightroom and see if this problem still persists?


Hi Nate,
I just upgraded from V2.X to V3.0.2. The Auto WB options are not working inside the NLP’s dialog. See attached image (cant attach more than 1). Selecting any of the 4 “auto” options (auto avg, auto neutral, auto mix, auto warm) results in the temp and tint slider to be at -0, -0 respectively. The color temp/tint on the photos doesn’t change as well. All other options like standard, kodak, etc are working just fine. Any suggestions?

I’m on Mac with m1 pro with MacOS13.3.1 using lightroom classic V12.4.

Screenshot 2023-08-12 at 12.28.34 PM

Getting this error when I try to activate vintage toning. I can hit okay but then the pop up happens whenever I try to do anything else other than cancel. Mac OS 13.2.1 and Lightroom Classic 12.4

Hi Nate,

I’m running the latest version of Lightroom Classic on Windows 10 and I’ve had some strange behaviour. As addressed by you before, the first time I tried opening v3 it inconsistently responded, but this seems to have fixed itself after a reinstall. I’ve been able to unconvert and reconvert negatives I’d used v2 on without issue.

However, one particular role has an issue: NLP doesn’t recognise that it has converted the images with V2, and so does not offer an “unconvert” button, only “convert” (which treats the positives like negatives). I haven’t had this issue with any other role so I assume it’s some kind of metadata or catalog issue; what should I try?


I know you weren’t asking me, but doesn’t ‘reset all’ on the photo in LR do the same? you’ll have to do WB again, once.

Any input is appreciated!

I thought about that, but I feared it’d reset the extensive dust removal I’ve done on the roll; I guess I could manually delete everything NLP changed from the history, just a bit tedious.

1 Like

Hi, I couldn’t figure out how to add my problem, so I am “replying” to you. I hope that is correct.

I have installed V3 successfully, and it seems to work perfectly. My system is a new Mac M2 Max running Ventura 13.5. The version of Lightroom Classic I’m on is 12.4.

I have just freshly dSLR-Scanned a fresh roll of B&W. I am using. Nikon D810 and 105/2.8 Macro. No changes to the camera settings since I started using it back in October. But now I notice that when I take each shot, each is showing up with a VERY blue cast. I don’t remember this from before V.3. Also, when I Ctrl-N to trigger NLP V3, the setting for Black and White is set, but when I apply it, my finished image comes out with a VERY purple/magenta cast. I cannot solve this. I have tried converting the images to Black and White using Lightroom before triggering NLP, but with no change.

With this computer, I tried using v 2.4 [EDIT: Not 2.4, the 3 Beta] by copying over the profile from my older MacBook, and it actually began to work, but there were errors. I did deactivate that, removed it, and installed this version 3. What can I try?

EDIT: Also, the new version 3 seems to remember a few test profiles from my earlier attempt to transfer the 3 Beta over. I wonder if that has anything to do with it?

After working on it for several more hours, I am now pretty sure that my problem lies somewhere between my new computer, the Mac Studio M2 Max running Ventura 13.5, or the install of Lightroom Classic (latest). Everything works perfectly on the MacBook Pro using the V3 Beta NLP. I am trusting that the newest version of NLP (v.3.02) works. I would like to install that on my MacBook, but I am hesitant because I know that the Beta on my laptop works perfectly and I don’t want to screw anything up.

The issue begins as soon as I release the shutter of my Nikon D810 tethered to the M2 Max. Black and white negatives are popping into Lightroom extremely saturated blue, like turquoise, as if a profile is missing our completely wrong. I noticed that on the M2, there was no “Camera Standard” like there is on my MacBook Pro. So I copied /users/Tony/Library/Application Support/Adobe/CameraRaw/CameraProfiles/Index.dat from my laptop to the M2 Max and voila, Camera Standard showed up and I thought things would work better. Nope.

My next step is to untether the camera and use the CF card to see if that makes a difference.

Hi @kzale1249 - is this happening on new conversions? Or when you open NLP on old conversions? If the conversion was made with an old enough version of NLP, it is possible that it might be missing the data needed for the Auto WB options, in which case, you would need to go to the “Convert” tab, select “Unconvert” and then hit the “Convert Negatives” button to redo the conversion. Can you let me know if that works?

Hi @analog_hotdog - does this happen consistently on all images? Does it happen on fresh conversions as well as old conversions? I haven’t been able to replicate this issue so far.

I’m curious what the visible metadata says for the photos in this roll… if you go to the Library module, then select the “Negative Lab Pro” metadata on the right side, you should see details about the file, if it has been converted. If you don’t see anything there, then it is missing the metadata and there isn’t really anything you can do about it…

Screen Shot 2023-08-15 at 4.44.42 PM

If you wanted to reset your photos in Lightroom, but still keep your previous dust removal work, the way to do that would be:

  1. Open up a fresh photo in Lightroom that has not been edited
  2. Hit Ctrl+C then select all the settings EXCEPT the “Healing” setting
  3. Then select the rest of the roll (while in the Library module) and hit Ctrl+V to paste those settings.

That will reset all the settings except the healing brush edits you made.

Hi, @TonyRowlett - from the sample image you shared, if you go to “Roll” make sure that it is set to “This Image Only” - you could get a strange cast if you were trying to use a Roll Analysis from a color film roll on the black and white image.

If that isn’t the issue, would you mind sending a RAW file to nate@natephotographic.com so that I can take a look and see if I can replicate the issue on my end?

Hmm, that’s odd… the other thing to look at would be if you happen to have some kind of default preset being applied by Lightroom as soon as the image is imported. One way you could test this is to reset the photo by going to Settings > Reset All Settings in Lightroom immediately after it is imported, and see if that makes it appear more like you would expect.

Correct. This is on a photo that was previously converted with v2.4 (i think, V2.x for sure). I did some testing myself. I downgraded LR Classic to v12.3 and:

  1. unconverted the photo and reconverted, it didn’t work.
  2. unconverted, hit apply, then reset photo in develop tab of LR. Then opened NLP and reconverted. Didn’t work.
  3. Removed photo from LR, then reimported them. This fixed the issue. I have not tried updating LRC back to v12.4, but i suspect that there may be a little glitch within LRC. However, all is good!