V2.3 NLP will not open in lightroom!

I am running Lightroom Classic on windows and when I click on NLP under the plugins tab nothing happens and it doesn’t open. Sometimes when I restart the computer it will work once or twice and then it will stop opening. This has literally only just started being an issue for me tonight.

I have tried deleting the plugin and readding, I have tried redownloading and reinstalling but so far have had no luck. Any ideas?

Thanks

Hi @iancawood

A few things to try (in order) to figure out what has gone wrong:

  1. Try resetting your Lightroom preferences. After you reset your preferences, you will need to go back into “file > plugin manager” and add back in the “NegativeLabPro.lrplugin” plugin. If there is an issue with metadata or conflict with another plugin, this should clear it out.
  2. Try restarting Lightroom Classic, and importing completely “fresh”, untouched negatives. See if Negative Lab Pro will work properly on those fresh negatives. If that works, there could be a metadata issue with the existing conversions.
  3. If that still doesn’t work, try creating a new catalog in Lightroom, then add fresh negatives, and see if those convert.

Let me know if any of those enable you to open NLP.

-Nate

Thanks Nate. Option 2 seemed to work. (Didn’t give option 3 a shot).

So if the metadata on my old negatives is the issue how do I fix this? Can I? I really don’t want to loose all the data with my many many rolls put through NLP!

I just tried making a whole new catalog and importing everything over to that. It appears to be working now which is grand! No idea what the issue was, but thought it was good to update if someone else has this issue!

Ian

Hi Nate, unfortunately this did not stay working. It’s now not opening again.

Any further suggestions would be much appreciated, it’s very frustrating.

Cheers,

Ian

Ah bugger!

Did you try option 1 (reseting your Lightroom preferences) and did that have any effect?

If option 1 didn’t have any effect, would you mind doing the following:

  1. Select a single image (which won’t open in NLP).
  2. Go to “file > export as catalog” . Make sure to check “Export selected photos only” and “Export Negative Files”
  3. Email that to me at nate@natephotographic.com and I will have a look

And very sorry for this frustrating experience! I still haven’t been able to replicate this issue on my end, so it is difficult to diagnose, but maybe the catalog itself will give me some clues.

-Nate

Yes sorry I should have clarified that I did try option 1 - I just gave it another shot and it hasn’t fixed it.

The issue only happens some of the time. Generally I’ve noticed it starts when I try to edit one particular roll. I use the multiple select and then open NLP feature a lot since it’s been released with V2.3.

So I opened each file in the roll individually in NLP and I believe the error starts as a result of an edited TIF file that I opened in photoshop and then was reimported back into the folder when I closed it. If you open this file individually it gives an error in NLP (as it should - something about the fact it’s not a negative) and then NLP continues to work fine. However it seems if you multiselect photos (with the TIF included) and then try to open it NLP will just not open. And then all subsequent attempts to open the program fail.

I kept having this issue simply because I kept going back to trying to edit this particular roll of film and kept multi-selecting.

What I will do is send you over the TIF file so you can see if you can recreate this error? It may be this is not the actual cause and there is something else wrong at my end… If it does do the same for you potentially then it is a minor bug?

Let me know what you think.

I am also encountering this error. Working on an M1 iMac 2021. Anyone have a remedy?

Hi,

Are you trying to re-open photos that you had converted with an older version of NLP, and they are not opening? If so, I can email you a beta of v2.3.1 which should address this issue.

-Nate

No, I have only been using 2.3

Hmm, ok. Have you tried the recommended steps from earlier in the post?