V3 Issues & Fixes Thread

Ok, glad that fixed it! If you run into this issue with any other previous conversions, can you do something for me?

  1. Select the image that is having this issue
  2. Go to File > Export as Catalog
  3. Make sure that “Export Negative Files” is selected
  4. Email the zipped catalog to me at nate@natephotographic.com

This way, I can take a look at the LR Catalog metadata associated with the file, and I may be able to discover what exactly has gone wrong in this case!

Ah, yeah, checked the metadata and there was nothing from NLP. Dunno why that roll in particular had this issue, but all is well now – the copy/paste settings solution worked wonders. Thanks Nate, V3 has been a blast!

OS - Ventura 13.5.1
Lightroom Ver. 12.5 Camera Raw 15.5
NLP version 3.0.2

In the advance tab, the Engine Settings defaults to v2.3 instead of v3.0+
I need to change this every time.

Appoligies if this has been asked before or I’m just missing something.

Ventura 13.4.1
Lighroom 12.5
Scans: fresh scans from Sony A7iii - 5 rolls of various b&w stock.

I converted a few of these with 2.x then upgraded to 3.0.2, unconverted the few individual shots I’d tried, then converted everything with 3.0.2 (confusingly these all seemed to say the engine was 2.3 for a while; can’t remember what I did about that). I tried 1-2 rolls with roll processing, read somewhere it’s not useful for b&w, then did the rest without roll processing.

I’m about halfway through going through image by image and touching up the NLP settings and hit a couple of photos that looked like they had converted wrong, or were 2.x conversions that went goofy. Very flat and overexposed.

I figured okay, I’ll unconvert and re-convert these few. But the NLP un-convert button said “un-convert 151 negatives.” That seemed wrong - I only had the one photo selected - and bad, so I tried Reset. That said single image in the confirmation dialog so I did it.

Now as I go back through my earlier negs, in the LR loupe view they look as they did during my image-by-image touchup, but when I cmd-N and open NLP, they change and I guess reset to “LAB - standard” with everything zeroed out, and nothing selected in the “settings” dropdown.

I suspect I accidentally / unknowingly reset all my photos. Am I screwed? Is there a bug somewhere in this long description? Is this likely to bite me again?

When you go through and “unconvert > re-convert” images, it will still hold on to the previous edit and engine settings in NLP (by design). Only the underlying image analysis will be updated. So what you are seeing here is expected.

You can quickly update any of the settings though across lots of images using the “sync” feature. So for instance, if you wanted to sync the updated engine settings across multiple images, just select that in the sync dialog, like this:

I’m going to guess that they probably were including some of the film holder or light panel in the current cropped area during conversion, and didn’t have “border buffer” set high enough. You should be able to unconvert just these images, then ensure that the no film holder or light panel is visible during conversion.

Hmm… if it said “un-convert 151 negatives” then 151 negatives must have been selected. In Lightroom, if you have a large selection, and then later, click just one photo, it just makes the photo you clicked on the “active photo” but it does not unselect all the other photos. You can go to “Edit > Select only Active Photo” to make the active photo the only selection.

I should probably update the UI because I understand that the word is misleading, but the “Reset Photo” command will apply to all currently selected photos (not just the main active photo). I will make this clearer in the next update.

If that LR selection thing got me, that would be pretty funny. I’ve used LR for a million years and double-checked my selection, but it’s still 100% possible - the UX is a little confusing. (And yeah I agree on updating NLP’s Reset language.)

So I assume my NLP settings are never coming back for those 150 photos yeah? Not a huge deal to redo them, but a head-slapper.

Unfortunately I think that’s correct. You should be able to use the history panel on each image to go back to the way they appeared beforehand, which may be useful as a quick fix, but you won’t be able to further edit them in NLP without the settings metadata attached - so to further edit you will basically need to re-edit.

Fair enough / lesson learned!

While I’m here, did v3 change anything about b&w conversions? All these photos are b&w and I’m finding that all my scans are requiring me to max out (or nearly max out) brightness and/or exposure. Especially if I start from Linear Gamma. Lab Standard is less severe.

These negs are a little thin, but I’m still finding myself surprised by where my scans drop me off to start.

Yes, the default “preset” for B+W photos is now using the “Linear + Gamma” profile, which most closely models the gamma of black and white photo paper.

If you want to change this back, you could create a new preset using the “Lab - Standard” profile, then set that new preset as the default.

There is a lot more flexibility in v3 in terms of what initial settings are applied, so the choice is yours!


I noticed that - and maybe it’s just the L+G profile but I find that for a lot of b/w conversions I barely have enough headroom with the Brightness & Exposure controls, which feels wrong. (again Lab Standard is very different). Happy to send you a few RAW files if you’re curious.

btw probably 75% of my NLP usage is b&w(!).

OS-Windows 11 Home 22H2

I’ve finally got some time to install V3.0.2 and I’m having the “Authorizing… Please Wait…” error that was described as an issue you’re tracking.

My license activation gets stuck on “Authorizing… Please Wait…”
If you try to activate your license and it gets stuck on “Authorizing… Please Wait…” then the issue is likely that you have entered the wrong license key. (It should be displaying a message that the license was not found, but there is a bug preventing that message from being displayed, which will be fixed in v3.0.3). Carefully copy and paste the license directly from the original email.

However, I know I’m using the right license as I’ve received it in two emails that say it’s the new license, and I logged into Lemon Squeezy and it showed me the same license. It was listed as inactive there, but I presume that’s because I haven’t activated it, yet. Or, could that have something to do with my issue?

I’ve reset my computer multiple times. I moved the plug-in folder and re-installed it. I installed it in a different location and manually added it. I’ve turned off the Windows Firewall, and I’ve verified that my PiHole was disabled during authorization.

What else can I try? If you need any more info, please let me know.

Would love to get this resolved ASAP, as I finally have some of my catalogs and images transferred to my new computer and need to run some conversions on client photos I am processing. Thank you for your help.

Basically right now, any error during activation will cause it to hang rather than report what the issue is.

Yep, it is just listed as inactive since it hasn’t been activated.

Hmm… I would guess that the issue is somewhere there? But let me get the error reporting fixed and maybe that will give us a better idea…


Success! Since you said you thought it was still something related to the internet connection/firewall, I thought about how else I could connect. I set-up a mobile hotspot with my phone, connected the computer wi-fi to that and unplugged the ethernet, and was able to activate the license.

So if anyone else has this issue, maybe they can see this and try that as a workaround. Thanks for your help in getting me to think about what other options I might have.

Hey Nate, weird new error – after unconverting and trying to reconvert w/ roll analysis a group of pictures from the last version, I’m getting the following: “an internal error has occurred: bad argument #1 to ‘insert’ (table expected, got nil)”. This happens after the progress bar goes through the 30-odd photos, and in the end no conversions are applied.

However, the next time I open NLP on the photos, they automatically switch back to full colour, but without roll analysis (so I think it’s just reapplying the old settings from before the initial unconversion.)

Hey Nate – all of a sudden, there are no presets to be found in the edit tab. I reinstalled, and the.pkg file has nothing in the presets folder.


I have this issue in the roll management tab.

The first time I open the analysis dropdown some options are missing.
If I press Manage Groups… then Cancel and then open the dropdown again, then the missing options appear.

NLP is showing “Could not locate LUTs” and all the info on the forum deal with the old installer so I’m not sure how to resolve with 3.0.2. Any help would be appreciated


fixed it! I didnt have them enabled in manage presets

Careful with Lightroom 13…

Awesome! Yep, that is exactly what I was going to recommend!