NLP can not be loaded to LR

This is my first post with a really bad problem: I used NLP with Lightroom CC for approx one year without any problems, it worked perfect. Suddenly I had trouble with my LR and could not open it anymore. The adobe service was very helpful, I had to reload my LR and it works well. But NLP was disappeared. So I tried to add it on Lightroom but surprisingly it not possible anymore. It is written, your program can not be loaded. This is really very bad. I spent hours in front of my Mac to solve the problem, but nothing helped.
Does anyone of you have a solution?
Thanks in advance

Hi Marc and welcome to the forum.

How did you “add” NLP to Lightroom? Have you run the NLP installer for this? You can also check if everything necessary sits in the right place. Here’s what the installer logs during installation (I’ve edited the text for clarity)

Installation of NegativeLab Pro for USERNAME
Note: USERNAME stands for your account name that is also
shown in the finder sidebar next to the home (house) icon.

  1. Installing custom camera profiles to
    /Users/USERNAME/Library/Application Support/Adobe/CameraRaw/CameraProfiles/NegativeLab Camera Profiles/
  2. Installing enhanced settings to
    /Users/USERNAME/Library/Application Support/Adobe/CameraRaw/Settings/NLP Enhanced Settings/
  3. Installing custom VueScan profiles to
    /Users/USERNAME/Library/Application Support/Adobe/CameraRaw/CameraProfiles/Vuescan Profiles/
  4. Setting up negative lab shortcut key [ctrl + n]
  5. Adding shortcut key for Lightroom Classic CC
  6. Adding Negative Lab Plugin to following directory:


  • Restart Lightroom
  • Go to ‘File → Plugin-in Manager’, then click the ‘Add’ button
  • Select ‘NegativeLabPro.lrplugin’ and click ‘Add Plug-in’
    (If you don’t see it, navigate in the dialog box to this folder: /Users/USERNAME/Plugins/)
  • If you’ve already purchased Negative Lab Pro, add your license number and click ‘ACTIVATE Negative Lab Pro’
    (otherwise, you can take Negative Lab for a test drive in trial mode)


I had cases that did not install the shortcut (steps 4 and 5) properly. In such cases, the guide has the necessary info for a manual fix. Note that the plug-in has to be in a folder that you have full access to. This is why Nate’s installer puts it as shown above. The order of the installation does not matter (if you do it manually) as long as you follow the post-install-instructions.
Hope this helps.

Hi @Marc,

Are you on Mac by chance?

If you get the error that “This Plugin Cannot be Loaded”, it is probably because you are trying to load the installer instead of the .lrplugin file. The .lrplugin file will be located in “home > plugins > NegativeLabPro.lrplugin” - you may need to navigate there in the plugin manager to find it.

See this article:

Thanx a lot for your help; if I am at home, I will check it immediately!

Hi Nate,
Thanx a lot for your helpful comment. I will check it at home and report how it ended!

Thanks a lot Nate you made my day!!! I tried it with labpro.lrplugin and it worked!!
I am very happy!!!
Again thanks a lot

1 Like