Trying to convert. Nothing happens

I am super frustrated. I have 15 images I am trying to convert but each time I click “Convert negative” with all of them selected OR even just one at a time, the plugin acts like it’s converting and then nothing happens to the files and the “Convert Negatives” button shows up again. Even when I try to convert one image at a time It took me about 6 tries to get the first two to convert and now the rest never convert.
I am using Lightroom CC on macOS Catalina.

I tried the demo version first and never had this problem.
Thanks for your help.

Hmm, that’s weird. And sorry for the frustrating experience!

Do you mean Lightroom Classic? Or Lightroom 6? If Lightroom 6, make sure you have the very latest version they made (I believe it was 6.14).

Has anything else changed in your setup since you were doing it successfully on the demo version? Activating the license on the demo version just removes the restrictions, it doesn’t change anything else…

I’d try these in order:

  • Make sure Lightroom is up to date.
  • Make sure you have enough hard drive space on the drive that Lightroom and NLP are on.
  • Make sure if your images are on any kind of external or networked drive, that the drive is connected.
  • Resetting the images giving you trouble (select them in Lightroom, and hit “command + shift + r”) and trying to convert again.
  • Restarting your computer
  • Resetting Lightroom Preferences (https://www.lightroomqueen.com/how-do-i-reset-lightrooms-preferences/) and then reinstalling Negative Lab Pro.

Again, sorry for the issue but hopefully one of these steps will help!

-Nate

Thanks for the quick reply Nate. I’ll answer your questions below. I also got a screen capture of the problem. I should mention a few things that I didn’t mention.

  1. My scan is a PNG (not TIFF) but that never was an issue before.
  2. My film was poorly developed (by myself) and the negative is definitely not great quality.

Do you mean Lightroom Classic? Or Lightroom 6?
CC is creative cloud I believe. Screen Shot 2020-04-11 at 1.41.30 PM

Has anything else changed in your setup since you were doing it successfully on the demo version?
I don’t believe so.

I’ve done these steps already:

  • Make sure you have enough hard drive space on the drive that Lightroom and NLP are on.
  • Make sure if your images are on any kind of external or networked drive, that the drive is connected.
  • Resetting the images giving you trouble (select them in Lightroom, and hit “command + shift + r”) and trying to convert again.
  • Restarting your computer

I thought maybe my negative was just so dark that it could be part of the problem so I did another try with a much brighter version of the same negative and still no luck.

Here are the two videos:


I’ll try installing negative lab pro again now.

Also I misspoke and I do think I remember wasting a few of the free trial scans because of this issue as well.

Removing the plugin, reinstalling and trying again didn’t seem to do anything.

Negative Lab Pro is not intended to be used with PNGs.

The underlying image analysis tool would need a PNG delegate to recognize and do analysis on different types of PNGs. Earlier versions of Negative Lab Pro didn’t include a PNG delegate either, but it may have worked on some systems because it wasn’t explicitly excluded and it may have found your a DLL (dynamic linked library) on your own system.

In any case, NLP is not made to support PNGs.

Ok. I will rescan as TIFF but that doesn’t quite explain why it works for some PNGs and not others. I would expect it to be all or nothing. I’ll let you know if that solves the problem.

I’m a little surprised any PNGs have worked for you with the newest version… but it could have to do with how they are compressed. Like I said, in a previous version, it was possible that some PNGs worked by “accident” but they weren’t really supported then either.

A quick way to convert existing PNGs to TIFs in your library…

  • Select the PNG images
  • Right-click > Export > “NLP - Positive Tiff Copies”

This will just create copies of the PNG that are 16bit TIF files. You can then run NLP on the tiff files and it should work.

Thanks for the reply and thanks for the tip. I almost rescanned everything haha… Unfortunately I am still having issues. Here is another screen capture using a TIFF.

Can you try updating to the last version of Lightroom CC 2015 (this is the same thing as Lightroom 6 but bundled for subscribers to creative cloud). I see that you are on 2015.1.1 - I believe the last version they made was 2015.14.0, but could be mistaken. (You can also update to Lightroom Classic if you still have a subscription to creative cloud).

It’s also a little weird that when you open the tiff, that it does not select the input source for you as tiff… it should do this automatically if it recognizes the tiff… but let’s start by making sure your Lightroom is up to date!

-Nate

You’re right. I realized my lightroom was not up to date although I originally thought it was. I installed the newer Lightroom Classic and restarted my computer. Still having the same issue. It’s also not detecting the TIFF as well.

I can try rescanning the negative tomorrow as a TIFF but let me know if you have any other ideas to try tomorrow. I am bummed because I obviously really want to use this plugin or else I wouldn’t bother going through all these steps to try to get it to work.
Thanks for your help.

Oh man, so sorry for this frustrating experience…

The only other thing I can think of is maybe some interference from other plugins or somehow your LR preferences got corrupted.

Can you try resetting your Lightroom Preferences (https://www.lightroomqueen.com/how-do-i-reset-lightrooms-preferences/) and then reinstalling Negative Lab Pro.

-Nate

Still no luck. I reset preferences, reinstalled the plugin and tried again. I took a screen capture again and noticed a quick message that pops up for a second while loading the plugin. I included a still image from the video here. Seems like a normal message about loading meta data. The last thing I’ll try today is rescanning the image.


And then it doesn’t default to the TIFF source type like before.

Hi, that message will also come up for a second when you open NLP. The fact though that it doesn’t default to TIFF input leads me to believe that something got messed up with the metadata somehow…

Can you try on a fresh image that you haven’t had trouble with before? Or remove some of those images from LR, and then reimport, and try on the reimported tiff?

I’m running out of ideas.

You followed the installation instructions exactly as in the included readme file, right?

Also, feel free to also send me a sample of a tiff that isn’t working…

That’s a great idea. I’d love to see if you have issues with the TIFF file as well.

by the way, some of my responses on this thread were marked as spam and removed. Not sure why. You responded to them though so at least you saw the replies before they were marked as spam.

The only step I missed from the guide was this
IMPORTANT: Make sure to TURN OFF the “Use Graphics Processor” option in Lightroom if it is enabled. To do this, go to “Preferences > Performance” and un-check the “Use Graphics Processor” option.

but I just tried that and restarted and it didn’t have any effect. I will try rescanning.

Nate. Not sure if you had a chance to try my TIFF but I rescanned the same image as a TIFF right now and it seemed to work this time! It auto detected the TIFF format and converted. I am still curious if that TIFF file I sent works for you though but I will say this is resolved for now. Until I rescan everything as a TIFF I won’t know for sure if it’s truly working or not but this is a good sign. Thanks for your help.

Hi!

Just tried and the tiff you supplied worked fine for me. Glad to hear things are working for you now!

-Nate

hmmm that doesn’t give me much confidence that the TIFF I supplied you that doesn’t work for me works for you but I am rescanning as we speak so I’ll see how the rest work.

Good news! I rescanned 17 negatives and successfully used the NLP plugin on all of them. Thanks so much for your help Nate.