"An internal error has occurred" when converting

Recently I have found myself unable to convert negatives.

I have scanned DNGs thru Silverfast, run the Silverfast prep utility, then white balance them. I then open up the NLP dialog with no problems and hit convert. It seems to go thru the whole process, but the image remains unconverted and I get this error screen ?:0: attempt to index field '?' (a nil value). Making any adjustments with the NLP dialog makes the error show up again. Finally, NLP believes it has converted the image and I have to unconvert to get it to try again.

I found a few other topics with similar errors that lead me to try deleting and reinstalling NLP, but this doesn’t seem to have resolved it. Unsure what to try next!

Screenshot 2024-01-12 at 6.50.54 🌃

Are you on the latest version of LR Classic? Are you using a custom preset as your default preset?

The only thing I can think of off the top of my head is that it could be that you have a custom preset that either isn’t available or is somehow breaking something?

What happens if you hit “apply” after conversion and those warnings… when you reopen Negative Lab Pro does it still show those warnings?

If it still shows those warnings, could you do this:

  1. Select the image which is producing warnings
  2. Go to “file > export as catalog”
  3. Make sure “Include Negatives” is selected (so that the image itself will be copied)
  4. Send the resulting zip to me at nate@natephotographic.com, and I can see exactly where the error is.

Another thing you can try which may resolve the issue is to reset your Lightroom preferences. This will reset Negative Lab Pro back to its default settings (you may need to install again after resetting preferences).


Apologies, I should’ve included more helpful info for diagnostics in my original post! Latest version of LR Classic, 13.1, and macOS Sonoma 14.2.1, running NLP 3.0.2.

I have no custom presets. NLP was working fine for me, and then I scanned a roll with Silverfast as TIFF instead of Raw to try out how it’s dust removal works and that’s when I encountered this error the first time. I rescanned it as DNG and it still seems to be happening with pictures from that roll, though files previously converted seem to work just fine still.

It does, this persists thru a restart of LR as well.

I reset my Lightroom preferences, but the error persists.

I’ve gone ahead and did the export as catalog and sent it your way. Thanks for the help.

Haven’t seen that exact error but recall something similar when using another plugin which couldn’t find a custom metadata field. You’ve not mentioned but worth having a look to make sure that the Update Silverfast/Vuescan menu button is adding NLP metadata?


I think it is, presuming that this panel is a good way of determining that:
Screenshot 2024-01-22 at 9.21.07 🌃

I noticed I was able to scan a new roll, and NLP worked ok. This lead me to rescan this previous roll in the same fashion to see if there was some weird Silverfast setting I had set that got reset upon restarting it.

I scanned 1 image, and was able to convert it no problem. But then when I scanned the rest of the roll and ran NLP, same issue. It seems now individually selecting images and changing the roll selected in Roll Settings → Analysis to This image only seems to resolve the error and allow the inversion to take place.

I’m also encountering this issue.
MacOS Version 12.6
Lightroom Classic CC 13.1
Camera Raw 16.1
NLP v3.0.2
Tiffs Scanned with Epson Scan

Roll Analysis On; NLP Standard Settings
When I turn Roll Analysis off under roll settings it works fine.

Yeahhh so I too have begun encoutering this issue!
Fresh install of Lightroom Classic 13.2 on Sonoma 14.2; Camera Raw 16.2
NLP v3.0.2
Successfully converted a bunch of rolls (both TIFF & RAW DNG scans from Silverfast 9)

Now have suddenly started getting this message when converting (both single file and whole roll):
‘An internal error has occurred.’
‘?:0: attempt to index field ‘?’ (a nil value)’

Toggling roll analysis off/on did not make a difference for me (as the error is also ocurring on single file).

I had the same problem when scanning with Silverfast. The issue was that the positive format was tiff instead of DNG.
Changed it to DNG and worked just fine!

I had the same issue And after deeper exploration I found out that “Update Vuescan / Silverfast DNGs” on a batch of scans (Multiple Files Selected) will update all files, however the “Read Metadata from File” will update only one scan (if in Develop Module, No issues in Import), not all selected. You have to do this one by one in order to avoid the error message.

PS. I am experiencing this on Mac, Not 100% sure if the issue is happening on my windows PC as well and I am not home now to check, sorry. (Might update the info eventually), I don’t use Roll analysis as my photos are probably not consistent enough due to occasional over exposure some turn out too dark and some are too bright, so I am not sure if that is the Actual cause of the issue.

Hope this Helps!
Have a great day.

If you switch to the “Library” module, then “Read Metadata From Files” will work on all the images you have selected.

Would you mind sending the TIFF that was having issues to me at nate@natephotographic.com?

Can you try creating a new catalog (“File > New Catalog”) and see if you still encounter the problem there? If you do, can you send some sample files to me at nate@natephotographic.com?

I still haven’t been able to replicate this issue.