SOLVED: "Negative.lua:708: attempt to perform arithmetic on field '?' (a nil value)

If you are trying to convert a film negative scan in Negative Lab Pro, and you get this message, then read on for the solution!

Negative Lab Pro depends on two key things to work: 1) the ability to analyze your negative image and 2) the ability to add metadata to your image about that analysis.

If either of these things isn’t working properly with your system or Lightroom, you may see an error like this one when you try to convert an image:


Depending on your situation, there are two potential solves for this issue.

SOLUTION #1: If this happens on EVERY photo, you need to move the plugin itself to a new folder

If you’ve just installed Negative Lab Pro, and you get this error on every conversion attempt, this is a folder permissions issue. You can usually solve this in just a few steps:

  1. Move the NegativeLabPro.lrplugin to the root of your main drive (like C:)
  2. In Lightroom, go to Plugin Manager, and remove the current Negative Lab Pro plugin, then add from the new location.

That’s it. In most cases, the plugin in now in a folder that has the permissions it needs to work.

SOLUTION #2: If this only happens on some photos, you need to reset those photos

If Negative Lab Pro works fine converting some images, but you find that any of those same images don’t convert properly in the future, you may need to reset those photos before re-converting.

  1. Select the photos where you are receiving the error.
  2. Hit “Cmd-Shift-R” on Mac (or Ctrl-Shift-R on Windows) to reset those photos
  3. Depending on the image, you may need to re-crop or re-white-balance. You may also need to hit “unconvert” in Negative Lab Pro the next time you run it on the image to then be able to convert again.

Hi, I just experienced this error after trying to install the updated neg lab pro plugin. I currently have the plugin on my desktop, but I’m not sure how to move it to the root of the main drive.

Can you provide some example on how to go about this?

Hi, are you on Windows or Mac? I can’t really provide support on how to move files in your operating system, but should be pretty easy to find online.

Did the previous version of NLP work OK? If yes, you just need to move the new NLP version to overwrite the old one. Make sure after doing this that you restart Lightroom so it can source the new files.

Also, if you are trying on images that were previous converted with Negative Lab Pro, you may need to fully reset those images, as described in solution #2 above.

I’m using Mac / Mojave.

The previous NLP worked just fine. But when I installed it, the error occurred. I’m sure it’s exactly like you said about overwriting the older version.

I was converting negatives that hasn’t been converted before the upgrade. Check the attached images. On my Light room plugin status, it says “plugin is enabled, but has encountered some problems”.


I guess my issue is, I’m not sure how to overwrite the older program since the new one just automatically appeared on my plugin manger, like there was no option to delete the older version.

Hi, are you sure 100% sure you are seeing error :708? Can you screenshot the error?

I’m guessing what you are actually seeing is error :42, which is unrelated to the main topic of this thread. (it was a problem with v1.3 that was fixed in 1.3.1)

You need to upgrade to v1.3.1 or later.

V1.3.1 link for mac:

When you upgrade you need to follow the steps here:

In your case, it looks like you have a custom path setup for your plugin (/Volumes/Tiano Extra Space/MAC-NEGATIVE-LAB-v1.3.0/source/NegativeLabPro.lrplugin).

You should remove this in the Plugin Manager, by hitting the “remove” button.


Then create a fresh installation following the instructions in the guide:

Solution #1 also seems to have fixed the problem I was having (error 667 rather than 708).