Version 1.3 - Pre-release Bugs and Issues

Find something not working the way it should in the pre-release of Negative Lab Pro v1.3? Let’s hear it!

Hi Nate

I get this message when I try to convert a negative.12

It’s a DSLR scan with a Sony A7rII

All was fine in the earlier version.

1 Like

Hi @Bo47 - I’ve updated the pre-release link on facebook to v1.3.1 which should solve this issue

1 Like

Same to me “Negative.lua:42: attempt to index field ‘conversionSettings’ (a nil value)” with Sony A7rIII

It’s the same problem for me.

Hi Nate

That did the trick :slight_smile:


1 Like

Yeah, it’s fixed now with 1.3.1!

1 Like

I am receiving that same error (above) when I try to convert.

I’ve tried:
• the new link with 1.3.1(via Facebook)
• I have tried the instructions on the guide.
• I have restarted lightroom several times.

A couple of details:
• I have CC and CC Classic loaded on my MacBook.
• I am running MacOS Sierra
• I have been using NLP for a few weeks now. Updated to the newest version tonight.
• Below is the log for the install:

​Beginning installation of NegativeLab Pro…
Installing custom camera profiles to /Users/joeysapple/Library/Application Support/Adobe/CameraRaw/CameraProfiles/NegativeLab Camera Profiles …
Installing custom camera profiles to /Users/joeysapple/Library/Application Support/Adobe/CameraRaw/CameraProfiles/Vuescan Profiles …
Setting up negative lab shortcut key [ctrl + n]…
Adding shortcut key for Lightroom 6…
Adding shortcut key for Lightroom Classic CC…
Adding Negative Lab Plugin to following directory: /Users/joeysapple/Plugins
cp: /Users/joeysapple/Plugins/NegativeLabPro.lrplugin/mac/libjpeg.9.dylib: Permission denied
Changing folder preference for Lightroom 6…
Changing folder preference for Lightroom Classic CC…



Restart Lightroom to finish updating your copy of Negative Lab

. . . . . . .


Hmm… when you go into the Plugin Manager, does it list the Negative Lab Pro version as 1.3.1? Or is it is still listed as 1.3?

I still see this problem. I have added “System Administrator” user with read/write permission, and put the addon in the Adobe CC add-on folder in the root library. This message appears not always but most of the time, and it does not seem to have any effect on the negative conversion.


@trondkj - to be clear, you are still seeing this error below exactly?

Negative.lua:42: attempt to index field ‘conversionSettings’ (a nil value) -

Is that correct? Or are you seeing a different error? Please screenshot the error you are seeing.

This is the one that I am seeing:


Hmm… Ok, this is a different error that I haven’t seen before.

A few questions:

  1. At what step in the process do you see this error? Is it when you try to “convert” the original negative image, or when you hit “apply” to close Negative Lab Pro?

  2. Were you by chance trying to make a tiff or jpeg copy?

  3. Does it happen on the same images again and again and not other? Does the problem on an image persist if you reset the image (Command+Shift+R on mac, Ctrl+Shift+R on Windows)

I see it when I click “Convert”, but not every time. I am making “digital contact sheets” of my old negatives, photograph whole strips, crop to the picture frame, then I convert the whole strip. This error sometimes also appears when I convert only one image.

I only convert raw, no tiff or jpeg.

I tried to redo the process, and got the same error, but on another picture I got another error :414.

I came to think of if this has to do with that the pictures are on a disk that is not always mounted. Will do some more testing.

If the image you are trying to convert is on a disk that isn’t currently accessible, it would definitely cause a problem!

Well, as long as I use Smart Previews, it should not be, and was not with the old version.

Now I did some testing with the disk disconnected. Still I get the error :2796: sometimes, but not always. All images got converted correctly.

The error :414: I have only seen on one picture, and it did not convert, but after a few tries the message disappeared and the picture was converted.

I’m getting the same error as some of the others above.

Lightroom Version CC - 8.2
NPL - V.1.3.1
Images - Sony .ARW RAWs

The conversion still works when the error comes up, not sure what’s causing it. It happens pretty infrequently. It seems to happen when I’m converting and image for the first time. I tried unconverting and converting again and they go through just fine.


Does this happen when you are trying to convert multiple images at once in batch mode? Or does it happen even on single image conversions?

Good question, I have a feeling it’s only when I try to convert more than one but I’ll do some more testing tonight and let you know.