Version 2.1 - Bugs and Issues

PLEASE READ BEFORE POSTING. If something doesn’t go as expected with Negative Lab Pro version 2.1, please do the following.

First, please look through Common Issues and Solutions and search this forum (using the magnifying glass icon to the top) to see if there is already a solution.

If your issue is not addressed above, please provide as much information about your issue as possible.

You should include the following when reporting an issue:

  1. Your operation system
  2. Your version of Lightroom
  3. Your version of Negative Lab Pro
  4. Steps to take to recreate your issue

Thanks!
-Nate


UPDATE: The following issues are addressed in v2.1.2, which is available to download now


"'Profile Missing Issue’
Fixed in v2.1.2
Even if the profile is correctly available, it sometimes shows a “profile missing” warning in Lightroom. This can happen when working with certain Silverfast files (it will try to load the camera profile instead of the scanner profile) or when you change the “source” to Vuescan/SF when working on a digital camera scan.

(It’s also possible if you see a Profile Missing error, that you either need to correctly add the camera profiles to Lightroom, or make photos from that scanner model compatible. You can ensure compatibility for Vuescan and Silverfast DNGs by going to “File > Plugin Extras > Update Vuescan/Silverfast DNGs” and following the prompts. After doing this, it should add Negative Lab profile to list and automatically select it. If it is STILL missing after doing this, make sure you are using a 48bit dng (not 64bit) AND re-check to make sure you have the camera profiles in the proper location. If the camera profiles are not in the right folder, you need to move them to the right folder and restart Lightroom.)


TIFF Prep Tool is overwriting existing EXIF Data
Fixed in v2.1.2


TIFF Prep Tool will not work if folder path to plugin contains spaces
Fixed in v2.1.2


ERROR: OUT OF LICENSES - This key has been used too many times.
Fixed in v2.1.2 - but if you receive the error, you will still need to email me after upgrading
If a very specific set of conditions occur when trying to register, license submission will throw an error, causing future attempts to fail to register but still increment your uses each time you try. If this happens to you, please email me at nate@natephotographic.com.

Hi Nate, I have just upgraded to ver 2.1 and have been testing it out on some dslr scans that I had successfully converted using ver 2.0. Using Lightroom CC 2019 (8.4.1), I took the previously converted color photo and reverted it back to the original dslr negative scan and tried converting it using NLP 2.1. My results are definitely not what I was expecting. Using ver 2.1 I get a super contrasty and blue hued picture. I have tried different settings but I am unable to get good results like I had in ver 2.0

I am using MAC OS Sierra 10.12.6

From ver 2.0

Thank you,

Craig

Here is what I get from ver 2.1

Hi, I’m guessing that resetting the photo in Lightroom (instead of using the “un-convert” option in Negative Lab Pro) has thrown things off a bit.

The process for re-converting is as follows:

  1. Select the image or images you want to re-convert
  2. Open Negative Lab Pro.
  3. Go to the “convert” tab
  4. Select “un-convert” from underneath where the “convert” button normally is. You need to use “un-convert” because this not only resets the Lightroom settings, but also lets Negative Lab Pro know that this has happened. If you simply try to reset the photo in Lightroom, this will make changes that Negative Lab Pro doesn’t know above and can hurt the process.
  5. After un-converting is done, adjust your settings and click the “Convert Negatives” button

If you follow those steps above, it should look essentially the same as before – given that the underlying camera profiles for regular digital cameras is the same in v2.0 and v2.1.

So there shouldn’t be any need to re-convert in your case because you are using a digital camera scan setup and are upgrading from v2.0 to v2.1. Re-conversion was necessary from from 1.3 to 2.0 because the underlying raw camera changed, and it needed to do a new analysis based on the new profile.

Reconversion IS necessary for Vuescan and Silverfast RAW DNG users because the underlying profile and settings recommendations changed.

Does that make sense?

Makes total sense Nate.

Thank you!

Craig Harding

Hi Nate,

I’m on Mojave 10.14.1
NLP 2.1
Lightroom Classic 8.3.1

I’m having issues with the profiles.

I’m scanning with Silverfast as 48bit RAW DNG using an Epson v850.

When I import into lightroom the profile on the right in the Develop module says NLP 2.1.

But when I open NLP the source is Digital Camera and then the profile says NLP 2 and there is an exclamation mark saying missing.

The I run the DNG converter that you mentioned and it works and then select read metadata etc but it keeps saying missing and showing 2.0.

Any ideas on what to do?

Alex

Having the same issue on my V850. I wonder if it’s because the profile is for a v800?

Thanks guys, able to replicate the issue on my end. Will push out a fix soon.

Hi Nate,

I’m using camera scanning, and I’m having a similar issue with already converted photos (from v2.0) being rendered very yellow after installing v2.1.
(Using OS X 10.15.1 Catalina, NLP v2.1, Lightroom 9.0)

Viewing file converted in v2.0 after installing 2.1:

Interesting enough, when I switch the file’s profile to “Negative Lab” it looks more like the last conversion I did. Unconverting and reconverting gives normal results again (and it still uses profile v2.0).

As you’ve mentioned, the profiles for camera scanning shouldn’t have changed between v2.0 and v2.1 so this is a rather curious problem…

It won’t let me post >1 image at once, but here’s the file under profile “Negative Lab”:

And finally after unconvert and reconvert (it gives profile v2.0):

Hi Nate,

Trying to convert a Vuescan file, I have the same problems mentioned here. Few more bugs:

  1. Lightroom reset button and 2.1 does not work anymore
  2. If you open NLP and click in cancel, will select a random picture from the Lightroom filmstrip.
  3. After convert with NLP, it will show the edit tab, but Lightroom still shows the un-converted image until you change something on the edit.
  4. Every time that you do apply a change with NLP, there is msg says “Saving NLP Settings”, which takes a long, long time.
  5. “Update Vuescan/Silverfast DNGs” reduce the file size by 33%, not sure if that expected. It also creates a new file instead of update.
  6. After “Update Vuescan/Silverfast DNGs”, I still don’t see the correct profile, so I need to select the profile manually.
  7. After converting a file, when opening it again will show the convert screen, to get to edit, needs to covert it again.

Using OS X 10.15.2 Catalina Beta, NLP v2.1, Lightroom 9.0

Oz

Hmm… based on the look of this, I’m going to guess that that file was originally converted using NLP v1.x, and then later re-edited using v2.0 (but without reconverting).If you use NLP 2.x on a file that was previously converted with 1.x, it won’t change the profile, unless you do the “un-convert - reconvert cycle”. Then I’m going to guess you either changed the profile manually to Negative Lab 2.0, or something else trigger this change… but in any case, if you change the profile here, you must unconvert - reconvert. The profile is like the foundation - if that changes, everything else has to change to.

In any case, looks like unconverting / reconverting solved it for ya!

Nate

Funny enough, I first started using NLP when it was on v2.0, so I’m still lost as to how this happened. Reconverting does fix it though.
Wondering if it’s some weird LR white balance issue, as I’ve seen it freak out when
using new vs old camera-matching profiles for my Fuji digital camera, giving vastly different white balances.

Woah :astonished: I think you may be having some overall system issues perhaps?

Note sure what you mean by the “Lightroom Reset Button”?

It’s probably going back one step too far in the undo stack… so it isn’t exactly random, it is going to the file you had previously selected… I can relook at this but I believe it was a small bug on Lightroom’s end…

This was an issue with Lightroom’s graphics processor acceleration in older versions of LR, but should be fixed as of Classic V9… for some slower machines, it may take a while for all the changes to apply. On slow machines, you may also find that it will run snappier if you turn off all graphics acceleration.

Every time you hit apply, Negative Lab Pro needs to write metadata to the catalog to sync state between the photo and NLP settings… this should only take a split second, so if it is taking a while for you, try closing out of any other open applications and freeing up more disk space.

Why do you believe it is doing these things? Are you sure you aren’t referring to using the Tiff Prep Utility? Because it’s possible that will reduce file size of the output tiff (with lossless compression) and it will always create a copy.

That’s not right… there should be a screen that says “loading metadata” and then go into editing automatically.

Not sure what to make of all these - I wonder if it has anything to do with being on 10.15.2 beta? I have a 2014 MacBook pro and everything runs really snappy.

It seems the problem is related to “Make Copy > TIF > Stack w/Photo”. The tiff file does not show up in the filmstrip, only the issues :slight_smile: After restart Lightroom, everything works properly.

I’m using a 2017 and 2019 MacBook pro, issues happens with both.

Reset the photo in Lightroom.

I’ve copies of the dng’s in external disks, the file I’m using at Lightroom was reduced by ~ 33% with a new timestamp.

Thanks

In Lightroom, stacked photos only show up when you are in the folder view of the library (not if you are in the “recent import” or a collection). You can “right click” an image and select “go to folder in library”, and then you will see the stacked photo.

When you hit the reset button in Lightroom, what happens? I’m not sure how the Lightroom reset button is related to Negative Lab Pro? Now, if you do reset the photo just using the Lightroom reset button, and the open it again in Negative Lab Pro, you will find that it goes back to the reconverted version… if you don’t want this to happen, you need to use the “unconvert” command inside NLP… go to the “convert” tab, and select “un-convert” towards the bottom.

Gotcha. It’s possible LR added lossless compression during import, but NLP is only changing metadata tags to DNG and should not change file size.

OH! This may be something… If Adobe made tweaks to a particular camera model, it’s possible that that would change… what camera are you using?

Yes, but is not adding to lightroom, need re-sync the folder (right click and select synchronize folder) and that will import the new tiff image.