V2.4 Issues and Fixes Thread

Hi guys,

I’m consolidating issues and fixes for v2.4 into this thread.

If you’re experiencing any issue with v2.4, this is the place to discuss it!

Updates in v2.4.2

:white_check_mark: Fixed Batch Mode issue where some images returned overly bright

There was a memory issue when batch mode was used in some cases, where the camera profile would not set before NLP began its analysis of the image, causing it to return erratic results. This has been resolved so batch mode should run correctly. As a side benefit of fixing this memory issue, batch mode should now run a bit faster. If you experienced erratic batch mode results, please upgrade to v2.4.2.

Thanks to @mattbeaty, @Lukeys.film and others for reporting and helping me resolve!

:white_check_mark: Unconverted images now correctly return to their previous crop on “apply”

As pointed out here, in some cases the border preview crop was persisting and not returning to the proper crop. Now, if you hit “apply” on an unconverted image while border buffer preview is active, the crop will correctly return to where it was before. Thanks to @vandebroek for pointing this out.

:white_check_mark: The Windows Hotkey can now only be triggered while Lightroom is active

As pointed out here, the previous windows hotkey could still be activated when Lightroom was not the primary window, causing potential conflicts with other shortcuts. This update ensure that the windows hotkey for Negative Lab Pro is only triggered when Lightroom is the active window. Thanks to @bcc32 for bringing this to my attention and providing a fix.

Updates in v2.4.1

:white_check_mark: The Windows installer now correctly runs for both LR6 and LrC users

In some cases, the windows installer was failing to run for LR6 users when it didn’t find Lightroom Classic. This has been fixed, and the installer will run properly for LR6 and LrC users on Windows.

:white_check_mark: Fixed issue with LR preferences not correctly updating on some systems

The previous installer attempted to improve compatibility with the LUT presets by telling Lightroom where to find them, but this caused unexpected issues for some users, so it has been removed from the installer.

If you installed V2.4.0 and notice any issues, then I’d recommend you do this (in order)

  1. In Lightroom, go to “Preferences > Presets”. If there is a “half dash” across the checkbox for “Store Presets With Catalog”, click it until it is what you want it to be (usually that will be having it unchecked), and restart Lightroom.
  2. Download and run the most recent installer (same link as in your email).

Step 1 and 2 should be enough, but if that doesn’t work, you will want to reset your Lightroom preferences , then download and run the latest installer.

:white_check_mark: Fixed Issue with Tiff Prep Utility Error

If you experience an issues with Tiff Prep Utility, please update to the latest version.

Getting error when running TIFF Scan Prep


:point_right: Can’t locate LUT

If your LUT or Saturation control is saying that it “can’t locate LUTs”, try these things (in order)

  1. In Lightroom, go to “preferences > presets” and make that “Store Presets with Catalog” is NOT selected. If it is “half-selected” with a horizontal line in the middle, click it twice to make sure it is unselected. Then restart Lightroom.

  2. If that doesn’t work, go to the “develop” module, and make sure the “presets” pane is expanded. In the expanded area, “right click” on any of the presets, and select “Reset Hidden Presets”

  3. If that doesn’t work, go to “File > Import Develop Presets and Profiles” and then manually add ALL the files from the following folders:

Mac: “HD / Library / Application Support / Adobe / Camera Raw / Settings / NLP Enhanced Settings”
Windows: “C:\ Users \ xxx \ AppData \ Roaming \ Adobe \ CameraRaw \ Settings \ NLP Enhanced Settings”

:point_right: "Camera Profile still shows 2.3? Did I upgrade correctly?

Yes, both the Camera Profile and Engine option will still be at v2.3.

The camera profile is like the foundation of a house. You don’t want to move the foundation often, unless there is a very good reason to do so. To date, I’ve gone through three camera profile versions (v1, v2 and v2.3). So most of the updates have not included a new version of the camera profile. The camera profiles will stay at 2.3 into the future unless I find a new way to improve.

:point_right: "Mac Ventura: issue if the installer is run from some folders

Issue: After running, the installer says “The installer has detected an error and was unable to complete the installation. Get in touch with the software manufacturer to ask for assistance”**

What’s happening: There appears to be a bug (or permission issue) with Mac Ventura that causes ALL package installers to fail when run from certain directories. Read more here: Install with Pkg file failed | MacRumors Forums

Solution: The solution is to MOVE the package installer to your Applications directory, and try running again from that directory.

1 Like

Hey Nate,

I’m experiencing an error while doing a batch conversion of a single roll of 35mm film. Prior to this error I did manage to convert a couple of rolls using V2.4. Here’s a screenshot of the occurring error.

It appears that the raw files are converted, but not showing up as being converted (I cant share the second screenshot due to restrictions for new users).

I’m also experiencing different results then I was getting with V2.3 and earlier versions, especially doing batch conversions. I read you mentioned it could be due to LR settings not being completely synced before hitting the convert button. This issue did not occur using the previous versions, and my workflow has not changed.

  1. Flip images
  2. Set whitebalance
  3. Crop out borders spaciously (I undo the crop after having done the conversion)
  4. Sync settings across the roll
  5. Batch conversion

Please advice, and thank you very much!

Hi Nate,

Unfortunately adding the LUTs manually did not work. I got a popup saying that they have already been added and they were still missing from the NLP module. I tried completely removing NLP and reinstalling AND manually plugging LUTs but that didn’t work either. I’m wondering if anyone else on windows has seen this issue? iIf not, I’m about ready to reinstall Lightroom lol. While I suppose it does still work in a sense that I can pick the scanner and the saturation level through the Lightroom profile tab but it’s slightly frustrating to do that.

Same for me (as mark2 above). On a Mac.
The “Store Presets with Catalog” was already unchecked.
And manually installing resulted in the notification that they are already installed.
(iMac 5k 2017, OS 12.6.1)

@gillevin @mark2

Thanks guys, that’s really helpful information. Good to know that the profiles are there, so NLP should be able to see it… We will figure out why this is happening in some cases…

There is definitely no need to reinstall Lightroom! There must be a set of conditions causing this to happen in NLP itself…

  1. Does it happen for both single-image and batch mode?
  2. Does it happen for fresh, new conversions, as well as for re-opening up an existing conversion?

Found a fun random bug after my installation of 2.4.
Figured I’d report it in case anyone else comes across it.

Mac OS Monterey 12.6
M1 Max
LR Classic 12.0.1

First conversion on any number of files (cropped and WB corrected) produces a terrible horrible no good very bad result. Too warm, too light, too flat.

Unconverting and then reconverting the same files with the exact same settings produces a much better result.

Note that the changes must be applied on the bad conversion, then unconverted, then the new conversion can be made which looks better.

Doesn’t appear to be consistent with any number of frames or type of image. Sometimes it’s fine, mostly it does this strangeness.
Doesn’t appear to change across different LUTs or profiles.
Also - unconverting a larger number of images tends to not actually unconvert them. Anything over 50 seems to misbehave (working on a roll of half-frame) with 80 photos and it won’t undo the conversion.

I’d like to roll back to the previous version for now until I have time to play with this more… but I can’t find a way to download it! Any help?

Ok, learning as we go. In the previous version I could select my images, pull up NLP and immediately press “convert” - and it would rock and roll at its own speed while I walked away.

2.4.1 will do the same thing, but I need to wait 5-15 seconds (depending on how many images are selected) for it to preview the exposure drop that it does before pressing "convert*.
If I wait, and I see the thumbnails get darker before clicking convert, the conversion looks perfect the first time.

From what I can tell, this takes a lot longer than it used to(?)

Anyway- reliably works. I can do a full roll of 36 at a time, or if I wait longer for the exposure drop (30+ seconds), I can do a roll of half-frame film.

No problem, happy to help. Yes, it happens for both single and batch mode on fresh and existing ones and the 48 profiles are visible in the Lightroom profile browser before even touching NLP.

Hi @mattbeaty

Yes, see above. Fix coming tonight. So sorry for the trouble!

@mark2 @gillevin

No matter what I try, I have not been able to replicate this issue with “Could Not Locate LUTs”…

I’m going to send a version of the plugin to you that will create a log that may give me a better idea of what is going on…

One quick thing you can do in the meantime just to check if it is a problem with Lightroom…

  1. Reset your Lightroom Preferences using this guide: How do I reset Lightroom’s Preferences?
  2. Re-run the latest installer (2.4.1)
  3. You will need to reenter your NLP key in “file > plugin manager”
  4. See if it now recognizes the LUTs

I tried resetting using the commands and also manually but still no luck. The log version sounds like a good idea, let me know!


Another user said they fixed this error by doing this:

  1. First, check in the “Presets” tab on the left pane to see if you have the “NLP Enhanced Settings” folder. It should look like this:
  2. If you don’t see that, right click anywhere inside the “Presets” pane, and select “Reset Hidden Presets”

If that folder somehow gets hidden, then NLP will not be able to locate it, so unhiding it should fix it.


Yeeeeep that fixed it! Thank you very much.

1 Like

FANTASTIC! :tada::tada::tada:

I was really scratching my head on that one, haha :sweat_smile:

Do you recall ever hiding those presets? It would be good to know if there is some other way that these presets might get hidden…

Hi Nate, I just upgraded and converting SF DNGs takes awhile compared to before. I’m on 14" Macbook Pro with M1 Pro and using Rosetta as instructed. Like I’m stuck on this for a long time:

Like it takes 10s of minutes. I don’t remember it being this slow before. Any ideas?

EDIT: Ignore me I forgot that I switched to keeping RAWs on Synology NAS :slight_smile:

I do recall hiding them but it was done by accident when creating a custom preset for sharpening. I didn’t think much of it at the time and NLP worked fine until I made the update, by then I had kind of forgotten about it haha.

1 Like

Thanks for confirming, @mark2! Just wanted to be sure there wasn’t something else in Lightroom or the installer that might be causing this!

I think I saw someone else say the same thing, but I have just scanned two new films in with 2.4 and the default output is veery different to the previous version. Basically the images come out way too bright and low contrast. I’m not sure if this is just the batch edit or single too, I will do some more tests tonight and get back with samples. It was very disconcerting at first as I was trying a new developer and I thought I had screwed up the dev process! :laughing:

Hi, this issue should be fixed as of v2.4.2.

Can you try downloading and installing the latest version (v2.4.2) and see if this resolves the issue for you? The link to download is the same as in your email.

I guessed you might have already fixed the issue with the update and tested it earlier, it seems to be fine now though I still need to test on some freshly imported images. Thanks for the fast update!

1 Like