Windows HotKey not working

Just updated to the new version of NLP (v2.2), but the Windows HotKey (Ctrl/Alt/N) is not working, even though NegativeLabHotkey.exe is running as a background process. Do I need to uninstall & reinstall this program because of the update? Running the latest version of LrC, btw.

Thanks!

Hey Alan, I’ve run into the same problem for a while now.
I once was able to fix it for one session by reinstalling completely but the hotkey didnt work after that one time either.
The bug seems to be unknown to Nathan, as I asked him about it on facebook yesterday but he didn’t have an immediate solution.
Happy to see I’m not the only one with that problem though!

Thank you for the feedback. It’s not a big deal…just surprised me. Hopefully, Nathan will see this thread, in addition to your FB contact, and he will eventually have a solution.

Well I personally feel like it hinders the speed of the workflow significantly.
When it stopped working I was, for lack of a more fitting word, pissed.
Do you know of any other hotkey solutions that might work with Submenus in Lightroom such as NLP?

I can certainly understand why a more high volume user than myself would miss having the hot key capability. I don’t convert all that many color negs (use another product for B&W) so it’s no big issue for me.

No, sorry, I don’t know of any LR solutions that can access submenus.

I’m not that high volume either to be honest. At least from my standpoint. However even fiddling with settings on one 36 exp film can be frustrating.
I’m currently testing things with Nathan and just found out that changing the language to English helps if you haven’t done that so far!

Change language to English for hot key? Anyway, I fixed it (maybe, only for now) by going into the Task Manager, ending the hot key process, then double-click on the application in the v2.2 download folders to restart it. Remains to be seen if it holds through a reboot…

Hi, nothing has changed in v2.2 with the hotkey - I suspect that there is some kind of interaction between the LR language settings, Lr versions, and the key combination.

For anyone who is having trouble with the windows hotkey, it would be helpful to know:

  1. What language their LR is set to
  2. The exact build of LR they are using (for instance, LrC 9.3)
  3. What hotkey combo they are trying to use
  4. What behavior happens when they hit the hotkey (for instance, does a different window pop up instead?)

If the hotkey causes something to happen in LR other than opening Negative Lab Pro, check out the instructions in the hotkey folder for trying different key combinations. If you experiment with the key combinations and find one that works, please post!

Nate,

As you can see in my post above, I got it working by simply ending the process and restarting the hot key application in the v2.2 folder structure. That said, however, and just for completion:

  1. LrC is set the English.
  2. LrC 9.4
  3. Ctrl-Alt-N
  4. Before my fix, absolutely nothing happened.

Perhaps there is an issue with LrC 9.4?

Hey there Nathan,

as you might guess I’m the one you already contacted through facebook so here are the closer details again:

  1. Language is German for me
  2. Version 9.4 of LrC
  3. Usually default shortcut but tried a lot of different ones.
  4. For me the survey window opens and it says “The photo has been selected as marked” or something along those lines in the English version.

Weirdly enough even when I try setting the shortcut keys to different ones, the behaviour of point 4 only happens when I press the default shortcut. Maybe that indicates that the shortcut isn’t properly changed somewhere under the hood?

Also sorry for the late reply, there is a 3 reply limit for new accounts on here.

Hi Nate,

I’m new in this forum because I’m a new user from NLP. Have the v2.2 updated from v2.1 and left the Hotkey.exe as it is from the v2.1 package but did not tested with that version. But now in the v2.2.
Result:

  1. Language is German
  2. Latest LrC version
  3. HotKey Process is running correctly
  4. Ctrl-Alt-N opens the survey window instead of NLP

The same result as KennethKrause mentioned in his post.

1 Like

Hey there Nate,

I have tested going back a few versions of Lightroom now and am currently back at 8.4.1 yet still the hotkeys don’t seem to work for NLP.
It really surprises me because looking at the pictures I have in my catalogue in this version I could swear the hotkey worked back then. So this might suggest something changed in the windows operating system as a whole that might interfere?
Not an expert at all of course but only thing I could think of.

Hope this helps,
cheers