Version 2.0 - Bugs and Issues

Find a bug or issue in Negative Lab Pro v2.0? This is the place to discuss it! Please include in the following info when submitting a bug:

  1. Your operating system
  2. Your version of Lightroom
  3. The exact path to your Negative Lab Pro plugin (you can find this by going to “file > plugin-manager” (a screenshot of the path works!)
  4. A screenshot of the issue you are having.
  5. Is this an upgrade from a previous version? Or is v2.0 your first install of Negative Lab Pro
  6. If this is an upgrade from previous version, PLEASE RETRY THE UPDATE INSTRUCTIONS IN EXACT ORDER. READ VERY SLOWLY. How to Upgrade Negative Lab Pro?


1 Like

BUG REPORT - lua:226

When getting back to a scan that already had been converted with NLP 1.3 I very often can’t reconvert and get back that error message. Tried with several scans and also on another Lr Installation on my MacBook. Files were made with Vuescan on a Reflecta RPS10M. Tried to reinstall NLP but no luck so far.

No problems with new scans. Seems to be, some of the old NLP-related metadata is written in the file that causes trouble?!

OS: Mac OS 10.13.6, Lr 8.3.1, Camera Raw 11.3

Update 20JUN2019: Error occurs also with scans I did yesterday in ver 2.0. So no chance to unconvert to change e.g. the colour model. Getting that above mentioned error when reconverting. Using virtual copy of that file doesn’t help either.

Hi, I’m not able to replicate this error… so let’s see if we can figure out what’s going on here…

Try this in exact order:

  1. In Lightroom, go to “file > plugin manager” and remove the current Negative Lab Pro plugin
  2. CLOSE Lightroom
  3. Run the v2.0 installer (
  4. Take a screenshot of the output of that installer and post here in this thread
  5. Start Lightroom
  6. Go to “file > plugin manager” and add the new Negative Lab Pro plugin
  7. Go to a negative you had previously converted, and open Negative Lab Pro
  8. Go to the “convert” tab, then select “reset photo”
  9. Hit “apply” (don’t reconvert just yet)
  10. Take a screenshot of your entire LR window (include negative image, histogram, and the “profile” - post that screenshot here.
  11. Reopen Negative Lab Pro and attempt to convert.

Hi Nate,

thanks for your quick reply.

Followed as instructed, but so far no luck.

Profile gets applied as expected, histogram doesn’t look strange to my eye.

As a sidenote: I usually use exiftool (Capture Time to Exif plugin within Lr) to change dates and save that (new) metadata back to the file by hitting cmd+s. May that cause trouble with NLPs metadata?

If of interest, I can send you a scan, just to check, wether my problem is file-related or due to some weird Lr stuff going on on my machine.

Ok, thanks… I see the issue… the issue is those brackets [] in the filename. The image processor thinks this is a special kind of command. I’ll issue a patch to fix this. In the meantime, you should be able to get it to work by renaming the file to something without brackets or any other special characters.

boom! you nailed it… if I delete those brackets in the filename… everything works as expected. Brilliant solution. :slight_smile:

1 Like