Two convertions always needed

Hi everyone,

I have this issue for a while and always shrugged it, but I decided it was time to share and try to investigate this.

Every time I convert Negatives, in this version and in the prior one, the first conversion is always terrible with 2 main aspects to it. It sets the negative to a heavy green tone and very under exposed. I always have to reset the conversion and do it again and then it comes out well.

It’s really setting and source independent. Happens with any saturation, which I usually have set at 3 or 4. Either if it’s a tiff scan or camera raw, color or black and white too. Yes even the BW conversion at first has this exact cast.

Here’s an example:

Has anyone ever encountered this issue? And if so were you able to fix this?


That’s very curious! A few questions for you:

  1. Are you on Mac or PC?
  2. Which release of Lightroom are you using?
  3. Which version of Negative Lab Pro are you using?
  4. Have you tried turning of Lightroom’s graphics acceleration to see if that resolves the issue? You can do that in “Lightroom > preferences > performance”

Hi Nate,

  1. PC
  2. 10.3 at the moment. It did happen before like with version 9.
  3. I am using 2.2, it used to happen with 2.1 too.
  4. Graphics card is already off since it’s needed for the white balance picker.

I looked around the forum and never seen anyone complain about such a cast except if they forgot to white balance, but for me it’s every single time I try to convert regardless of the type of scan and conversion (color/bw), so it’s unrelated to that. I hope we can find a solution as it will save some time :slight_smile:

Hi @nuno, can you post one of the images that give you the headache?
Use a sharing service if your RAW file is too big for the forum.

The image can help to see if we get the same green meany too and maybe find out if it might be an issue with your own setup. Adding screenshots of the first and second tab of NLP will help too.

Hi Digitizer,

Thanks for reaching out, the issue is that this literally happens with all my raws or tiff scans. I am not having issues with one single image, but literally all of them and only after the first conversion. Any consecutive conversion does the job properly. I have only tried up to third time.

Converting an image takes a few steps. Processing the same image on a different system can maybe eliminate one of several possible sources of your issues. Feel free to accept help or not. It’s your call.

I am here to get help, I was just trying to contextualize that my issue is not about an issue with a single image.

Here are the files - raw, first and second conversion

Tried the tiff file and had to reset it first, because it came as a positive.

The reset file does not play nicely with the “Cinematic-Rich” tone setting.
Other tone settings work better imo - and the file needs to be white balanced after the conversion.

In view of the fact that all your images get the green touch, I recommend that you try a different default setting instead. Balance the image as desired and then save the settings in NLP before pressing “Apply”.

Also, the “raw” file contained some information I had to get rid off before the conversion worked well.

  • Select the image
  • Reset all settings (in Library view)
  • Save settings to file

After that, I tried with standard and cinematic rich. Cinematic produced the green cast, Standard didn’t:

I think of NLP not as of a magic bullet, but as something producing a starting point, which can vary depending on a lot of things. If a setting does not provide the desired look, I try other settings and usually will get what I want after a few trials. The conversion you see above was made by changing the “Tones” and “WB” settings only - and nothing else. Removing the slight magenta cast in the curtain will need some extra care. Maybe even a tiff copy of the positive. Haven’t tried it though.

I have changed settings around. Different scanners and saturations. Nothing fix the fact that the first conversion comes out like I pointed out at the top.

Also, the “raw” file contained some information I had to get rid off before the conversion worked well.

Select the image
Reset all settings (in Library view)
Save settings to file

Interesting, maybe I need to do this in all my images, but I would like to then know what’s this extra information. Since both raws from my Sony and Tiffs from my pakon suffer from the same effect.

I think of NLP not as of a magic bullet,

Same here, I am just trying to find out where and how the voodoo that creates that green cast is coming from, since it doubles my processing time to analyse and convert all the negatives.

The first and second images from the original post are created with the exact same settings. The only thing which is what you might be one here, is that between the first and second conversion, I press - Reset Photo - and that might do that reset that you mention you did.

I will come back with my findings when I try to convert a roll again and use that resetting method first.


Your example image seemed to convert great with no adjustments… I just had to reset the image before converting to wipe out any prior adjustments.

A few things to check:

  1. Make sure you don’t have any settings or presets being automatically applied when you import into lightroom.
  2. Depending on the program these were captured in, it’s not a bad idea to just reset all the Lightroom settings prior to conversion. You can do that by selecting the photos you’ve just imported and going to “settings > reset all settings” .
  3. If that doesn’t solve it, you may want to try uninstalling, and then reinstalling Negative Lab Pro. The easiest way to do this is to 1) Close Lightroom, 2) Delete the NegativeLabPro.lrplugin folder (wherever you placed it during the initial install, 3) download a fresh copy, and move the new NegativeLabPro.lrplugin folder where the old one used to be, 4) Start Lightroom.


This is interesting indeed. As Nate mentions above, applying a preset on import in Lightroom can be the one item that changes both file types. I ran my tests with the default setting, which is adobe neutral plus CA correction. This should have gone away on reset though.

It would be interesting to see what an out of camera RAW file looks like, see if something is buried in metadata fields… A RAW file that has seen nothing but the camera.

Nothing has worked. :frowning:

  1. So I just import the files from location by synchronizing the folder so nothing is applied.

  2. I am resetting the settings, I don’t have that menu in windows, but I am doing Photo > Develop Settings > Reset settings. Is this the same that you mean? - I have done this with no success. The Green cast is still present in the first round of conversion.

  3. This has not worked either.