V2.2 C Stack Overflow?

So I run a lab in AZ, using NLP to convert hundreds and sometimes thousands of scans at a time. Previous to the 2.2 update, it would do as many as I asked it to, easily over 1000 frames at a time so I can walk away and have an adult beverage.

2.2 however, I tried a little conversion of 474 frames and repeatedly got a “C Stack Overflow” error.
It seems like it will do the exports and get everything ready, but then won’t actually finish the conversion. Clicking “Apply” on that many images throws the error.
If I go back and select smaller batches of prints, pull up NLP, it knows it’s done the work already and I can just click “Apply”, a hundred frames at a time or so.

I uninstalled and reinstalled the plugin, same issue.

Still getting this error, which seems to be related only to the size of the batch I’m trying to convert.

Mac OS Catalina 10.15.6
Latest LR. Fresh download/install of NLP.

Thanks @mattbeaty - a few others have noted this as well. I’m not aware of any changes in v2.2 that could be causing this, but I’ll do some benchmarking and see what I can do to improve it.

In the meantime, it may help to make sure your Lightroom is
optimized, which this article should help with! https://www.negativelabpro.com/guide/lightroom/#speeding-up-lightroom


Thanks for the reply, Nate! I’m still working my way through this and discovering more about it.

Interesting development (so to speak):

It’ll do as many B+W conversions as I ask it to with no problem. Thousand at a time, piece of cake.
Only struggles with color conversions.
For a batch of 99 frames, it will currently run through the whole process without throwing any visible errors, but when it’s finished, and I click “apply” - none of the changes apply. I have to bring up NLP again, then it will read the metadata and let me click “apply” again, then it finishes everything the way it should.

Who knows?