An internal error has occured: ?:0: attempt to index a nil value

I keep getting this error when I try to convert, i’ve posted about this before and had no replies, its been a few months and im sitting here with a plugin that doesn’t work.

Please can this be looked in to.

Hi, have you tried installing the latest version (v2.2) and seeing if that resolves your issue?

I have tried that.

After updating it did not work still, i then decided to try uninstalling and re-installing lightroom with no luck.

In LR, can you go to “File > Plugin Manager” and in the Negative Lab Pro window, scroll down to the bottom and take a screenshot of the whole thing, where it shows the version, location, and status?

Also, can you let me know at what point in the process this message pops up? A video would be awesome, but a detailed description will help.

Finally, can you share details about your system and setup? If you go to “Help > System Info”, just got and paste that first section, from the top to the “Installed Plugins” section.

-Nate

Hi Nate,

Here is a screenshot of version, location and status .

Here is a video of the process of the error occurrence

and here is my system info - Thank you in advance for looking in to this.

Lightroom Classic version: 9.4 [ 202008061458-dbb2971e ]
License: Creative Cloud
Language setting: en
Operating system: Windows 10 - Home Premium Edition
Version: 10.0.18363
Application architecture: x64
System architecture: x64
Logical processor count: 24
Processor speed: 3.7 GHz
SqLite Version: 3.30.1
Built-in memory: 32685.5 MB
Real memory available to Lightroom: 32685.5 MB
Real memory used by Lightroom: 1314.1 MB (4.0%)
Virtual memory used by Lightroom: 2955.2 MB
GDI objects count: 632
USER objects count: 1919
Process handles count: 1593
Memory cache size: 11.8MB
Internal Camera Raw version: 12.4 [ 555 ]
Maximum thread count used by Camera Raw: 5
Camera Raw SIMD optimization: SSE2,AVX,AVX2
Camera Raw virtual memory: 357MB / 16342MB (2%)
Camera Raw real memory: 363MB / 32685MB (1%)
System DPI setting: 144 DPI (high DPI mode)
Desktop composition enabled: Yes
Displays: 1) 3840x2160, 2) 1920x1080
Input types: Multitouch: No, Integrated touch: No, Integrated pen: No, External touch: No, External pen: No, Keyboard: No

Graphics Processor Info:
DirectX: NVIDIA GeForce RTX 2080 Ti (27.21.14.5655)

Application folder: C:\Program Files\Adobe\Adobe Lightroom Classic
Library Path: C:\Users\Adrian Eariss\Pictures\Lightroom\Lightroom Catalog-2.lrcat
Settings Folder: C:\Users\Adrian Eariss\AppData\Roaming\Adobe\Lightroom

Installed Plugins:

  1. AdobeStock
  2. Facebook
  3. Flickr
  4. Negative Lab Pro
  5. Nikon Tether Plugin

Config.lua flags: None

Ok, thank you!

Per your screenshot, it looks like you have tried to install it from “C:\Program Files\Adobe Lightroom Classic\Modules\NegativeLabPro.plugin”

It will not work if it is in that directory!!!

(I try to make this clear in the installation instructions for windows… the safest place to put it is in a directory you create directly on the root of your main hard drive, for instance “C:\Plugins” - I know other plugins work while in that program files “modules” directory, but Negative Lab Pro requires more file permission that other plugins to run the image analysis, so it just won’t work where you have placed it).

You need to:

  1. Move the plugin itself to C:\Plugins (or another directory you create on your root drive)
  2. Go into plugin manager, remove the current installation, then add from the new directory.

-Nate

I’ve tried moving it to the root of C:\ , i’ve tried putting it in to documents and i’ts still saying the same error :frowning:

Not only do you need to move the plugin, but then you need to go into the plugin manager and remove the old location, and add from the new location. If it’s still linking to the old location it will not work. Try that with the new version (2.2).

I did this several times, making sure to remove the old location and adding from the new location.

It still says the same error even when the locatio path is pointing towards the folder in \documents

This is on version 2.2

Ok, for any future troubleshooting, make sure that this is the case, because it absolutely will not work if it is pointing to the directory you had it in in your example.

Some other things worth trying:

  • Fully reset your Lightroom preferences. https://www.lightroomqueen.com/how-do-i-reset-lightrooms-preferences/ - you will then need to re-add NLP in the plugin manager.
  • Check and see if you have any sort of antivirus running, like BitDefender. If you do, turn them off. They can silently cause the image analysis to fail.
  • There was one case where I tried pretty much everything with a user, and in the end, they reformatted their computer, installed LR Classic, downloaded a fresh install of NLP, and it worked perfectly… so they had some sort of internal issue or conflict that we were never able to figure out, but it was resolved with a reset.

Hey man! I had the exact same problem and i’ve tried all these solutions with no luck either. What worked for me was to create a whole NEW USER on my computer, and install lightroom and negative lab on this NEW USER. It worked like a charm. I hope it works for you aswell. Cheers

1 Like