Can't activate license - ACTIVATE button does not react


When I fill in the License key in the field and then click ‘ACTIVATE’ nothing happens. No error messages appear either. There is no response at all. I have filled in the license key with and without dashes between the characters.

Some other things that I have tried doing before posting here:

  • I deleted the plugin and installed it again

  • I went back to an older version of Lightroom (version 12 something) and tried it there

  • I’ve tried restarting my laptop after every installation

  • I’ve checked this forum but couldn’t find a similar problem (maybe I overlooked)

Thanks in advance!



This usually means your are trying to use your v2 key on v3 (or trying to use your v3 key on v2). There is a different format used between v2 and v3 keys.

Just looking and in your case, it appears that you do have a v3 key, so make sure you are using that (and not a previous key). If you have a v3 key but can’t remember it, you can find it here: My Orders - Lemon Squeezy – Just enter your email address, and it should let you see any order information associated with that email.

If you currently have a v2 key and would like to upgrade to v3, you can use this link:

If you have a v2 key and want to redownload v2, any of your previous download links should take you to an area where you see a link to download v2.