Error Message when trying to convert .raf files

MacBook Pro Monterey V 12.5 I-9 Processor. Trying to convert Fujifilm raw files (.raf and tried converting to .dng). Images taken with X-T2 camera.Color and B&W negatives. Get message on both.

Here is the message:
as we were trying to run the AutoColor 2.0 script.

“/Users/dh/Plugins/NegativeLabPro.lrplugin/mac/magick” “/Users/dh/Plugins/NegativeLabPro.lrplugin/previews/00001.tif” -profile “/Users/dh/Plugins/NegativeLabPro.lrplugin/profiles/ProPhoto.icc” -gravity Center -crop 100x100%+0+0 +repage -blur 0x1 ( -clone 0 -channel R -normalize -channel G -normali…

Error Message:

Exit Status: 35072

Then I get this message as I close out.

An internal error has occurred.
bad argument #1 to ‘match’ (string expected, got nil)

Just tested a conversion with a X-T2 .raf file I downloaded from

Conversion worked as expected - without any issues.
Looks like your issue is something that @nate will have to look into.


It should work great with .raf files. I personally use an X-T2, and the sample files I share are also from an X-T2. So there must be something else going on.

  1. Have you been able to ever get NLP to work (on any files) or have you just installed and getting this error?
  2. Did you download the Mac version and install it using the included installer application? (You could get this error if you tried to install the Windows version)
  3. Do you have any other programs that might be interfering (i.e. anti-virus, etc).
  4. What version of Lightroom are you running?

Hey thanks for reply. For S & G’s I did a uninstall/reinstall…all is working now.