Error writing metadata

In my case, the exclamation marks caused by launching NLP remain until I take some action to resolve them. I just left Lr open overnight, then quit and relaunched it, and the errors were still there. Switching catalogs and then switching back also does nothing to resolve the exclamation marks.

Hi @iimd and @Digitizer,

Hmm… I’ve never seen this behavior myself…

A few questions:

  1. Is this a new behavior for you or is this something you have always experienced?

  2. Have you tried this with other versions of Lightroom or other versions of Negative Lab Pro?

  3. Do you experience this in both batch mode (with multiple images selected at once) and with just one image selected?

Also, a couple of thoughts that might help with the detective work…

First, the only circumstances that Negative Lab Pro will be writing metadata to IMAGE files is when you either 1) create a positive image copy or 2) select go to “file > export” and having Negative Lab Pro metadata options selected.

So would not be writing metadata to an original raw file on startup.

BUT, it is writing some metadata to the Lightroom catalog on startup… so it might worth checking your permissions settings on Lightroom catalog itself? It could be that this is treated differently on different versions of MacOS.

If you find this happens with large batches of images at once, but you don’t have the issue when opening individual images, that would also help narrow down to what is causing this for you!


I never had this issue with NLP 2.x and Lightroom in earlier subversions of 12.

Now, if NLP is writing to the database (no issue herewith), Lr will write XMP sidecars, if set accordingly. I always set Lr to not write XMP automatically and have never had the issue before. It seems to be related to writing to xmp sidecars, something that happens (asynchronously I suppose) if Lr is set to do so automatically.

I only got the issue when I tried to reproduce @iimd’s issue and my posts above tell the story of what I did. There might be something wrong with newer Lr 12 releases too, like threads getting in each others ways so to speak.

I tried several combinations of macOS userIDs and user and group rights with items written by the finder or by Lightroom. None of these combos provided something I’d call obvious cause-effect relations though. Moreover, the issue did not always appear with the same files, often the same, but sometimes with completely different files. This random behaviour makes me think that the issue is related to threads of Lightroom getting in their way, something that I have no idea about how to test. Maybe that Lr dev. tools can help, but that’s way out of my ballpark.

Thanks for looking into this, @nate.

In my case the answers are as follows:

I only started using NLP at v3.0.2 with Lr v13.x. I believe the problem has been there from the start with this configuration. It happens with DNG files. It does not seem to happen with ARW files on their own, but it sometimes happens with ARW files + XMP sidecar files. Enabling “Automatically enable writing metadata into XMP” in catalog settings does not prevent the appearance of exclamation marks with DNG files, but it does cause them to disappear after a couple of seconds.

No, but I’d be happy to try anything you suggest.

It happens both with a single image selected and in batch mode. In batch mode, not all files will necessarily get an exclamation mark on NLP launch, but most do. However, if I quit and relaunch, they will eventually all get exclamation marks. In my case, the exclamation marks that appear at NLP launch never end up disappearing (as @Digitizer reported with some of his files, in his scenario).

Regarding permissions on Lr catalog files. All files are 644. All directories are 755. My user has administrator privileges. The group for all files and directories is “staff”. Lr has full disk access in “System Settings…Privacy & Security…Full Disk Access”.

For convenience here again is my basic system setup:

Negative Lab Pro 3.0.2
“Negative Lab - Sony ILCE-6700 v2.3.dcp” (provided by @nate)
Lightroom Classic 13.1
MacOS Sonoma 14.2.1

1 Like

Just for the heck of it, I just installed Lr 12.0 with NLP 3.0.2. Same problem with the DNGs.

1 Like

Ran a set of three images with 4 VC’s each through NLP on Lr 12 on macOS 12 (all current)
Scans were taken at nominal, +1/3 and +2/3 exposure (from top to bottom, leftmost = WB’ed captures)
Virtual copies were NLP’ed with Basic, Frontier, Noritsu and B&W modes (from left to right)
Then, I manually saved XMP (I set Lightroom catalog to NOT do this automatically)
Then, I selected the three masters and started NLP → and got the “!” badge (error writing metadata)
Then, I converted the three masters, which worked without any hiccups
Then, I selected all images and made LR write XMP → and the “!” disappeared, the files were written indeed and showed the following access rights…which are different between the RAW and sidecars:
Bildschirm 2024-01-14 um

Test details

The method described above allows for easy, time- and drivespace-economic testing. We can also see that the difference in exposure does not change worlds in the converted images, NLP does a nice job to even out such differences. Colour rendition differs between the modes, but it is subtle with this negative and is almost swallowed by whatever the forum software does.