Internal Error/ Permission Denied

I have tried to reset permissions via another forum I saw on here. No luck! I am told that the permissions are denied, and then an internal errors.

… as we were trying to run the AutoColor 2.0 script.

Command:

“/Users/ashleystoecklin/Plugins/NegativeLabPro.lrplugin/mac/magick” “/Users/ashleystoecklin/Plugins/NegativeLabPro.lrplugin/previews/00001.tif” -profile “/Users/ashleystoecklin/Plugins/NegativeLabPro.lrplugin/profiles/ProPhoto.icc” -gravity Center -crop 100x100%+0+0 +repage -blur 0x1 ( -clone 0 -c…

Error Message:

sh: /Users/ashleystoecklin/Plugins/NegativeLabPro.lrplugin/mac/magick: Permission denied

Exit Status: 32256

Your paths look like Mac… If it is so, fiddling with permissions can spoil your joy.

I’ve put the plugin in a different place

At which the rights are as follows:
Bildschirmfoto 2020-08-09 um 22.20.33

Note that I’ve installed two user accounts, an admin and a non-admin user.
The plugIn itself has (from top down) r/w, r/w, r/w, r, r while "magick has rights as shown in the screenshot (taken from the non-admin user)

What are the rights on your Mac? Select the plugin and type cmd-I to see.

I just made the rights to Read & Write on all accounts. They were Read Only for some. But still no luck. Have also tried to uninstall the plugin and reinstall it…I’m ready to give up!! haha

I trust you did follow Nate’s guide

… have you also changed rights of objects within the plugin?

Are you on Catalina? Catalina seems to sometimes be messing up permissions. You can usually fix it following this guide.

https://www.catalinaosx.com/how-to-fix-permissions-issue-on-catalina-osx

Perhaps that is what you have already tried and it didn’t work for you…

If you do try that and it doesn’t work, the next thing I would look at is if you have any software running in the background that it trying to “protect” you. For instance, if you are running something like “BitDefender” it could be preventing the external scripts (like ImageMagick) from running and doing it’s thing.

-Nate