Solved: Mac Catalina permissions issues during installation or use

While Mac OSX 10.15 (Catlina) brings some great new features to Mac users, it also has brought its fair share of issues.

One of the biggest issues is the way it deals with security and independent developers. While this was previously pretty straightforward, the new way it deals with security can create complications where there shouldn’t be any.

Installation Issues and Fixes

1: "NegativeLabPro cannot be opened because the developer cannot be verified"

When trying to run the installation package, you may receive an “unidentified developer warning.”


  1. Control + Click” the Negative Lab Pro installer package
  2. Select “Open
  3. Then select “Open Anyway”.

It should then run the installer package properly, and you can follow the rest of the instructions to finish the installation.

2: The Shortcut Key (Cntrl + N) isn’t getting added

In some cases, you may find that the shortcut key (Cntrl + N) isn’t being set during installation. If this is the case, you can simply follow these instructions to manually add the shortcut key.

Conversion Issues

“Magick cannot be opened because it from an unidentified developer. Move to trash?”

If you get this error from your mac when you try to run Negative Lab Pro from inside Lightroom, here’s what to do:


  1. Hit “Cancel” (do NOT move to trash)
  2. Open up “Apple > System Preferences > Security > General
  3. Click “Allow Anyway” next to the warning about an app being blocked

You should then try re-running Negative Lab Pro and see if your system prompts you for any more warnings.

“ERROR: Could not write photo for analysis”

If you are experiencing this issue on Mac Catalina, this is usually just a general folder permissions issue.

Solution #1

  1. From the Finder , select the “ Go ” menu, then choose “ Utilities “.
  2. Open “ Terminal “.
  3. Type the following command, then press “ Enter “:
    diskutil resetUserPermissions / id -u``

(NOTE: Some users may need to run the command with “sudo” in front of the command:
sudo diskutil resetUserPermissions / id -u``)

Solution #2

If solution #1 doesn’t solve this issue for you, there could be other things that are preventing Negative Lab Pro from running as it should:

  1. If your images are on an external or networked drive, be sure those drives are connected.
  2. If you run any 3rd party “computer protection” services, like BitDefender, turn them off or white-list Negative Lab Pro
  3. If you did a manual install of Negative Lab Pro (not using the installer package), then check where you placed the NegativeLabPro.lrplugin file. This file must be in a location that you have read/write access to as a user.

Hope that helps! If any other issues come up that aren’t mentioned or solved above related to Catalina, let me konw below!


I am having the "ERROR: Could not write photo for analysis: issue and have tried both solutions but no luck making it work. If i revert back to the archived 2.1.2 version everything works fine but i cant get the new beta v2.2 beta to function