NLP always selects v2.3 instead of V3+

Hi Nate/All,

For some reason NLP always selects ‘engine settings’ v2.3 instead of v3. All install is good, v3 is there, I can reset photo and when converted again it triggers v3. Note, these are not previous conversions, I am aware that on previously converted negs I have to go through the reset photo to apply engine v3. These are new scanned rolls and imported into LR from an SD card after cam scans.

Anything I am missing, not doing it correctly?

LR: 13.2
NLP: 3.0.2
MBP: Apple M1 Max
OS: Sonoma 14.3.1 (23D60)

PS. The difference after going through aforementioned rest from v2.3 to get v3 are astonishing!

Thanks in advance,

Please check Lightroom’s Module Manager. It’s available under Lr’s file menu and should show all your plugins including the ones for NLP.

NLP 2’s plugin has no version number and should be deactivated.
NLP 3’s plugin has a version number and should be activated.

Here’s how it looks on my Mac, which is set to display things in German.
Bildschirm 2024-03-03 um

Plugins for NLP are installed here:

/Library/Application\ Support/Adobe/Lightroom/Modules/ 

Hi and TY for your reply.

NLP v3 is the only one installed and activated. Please see below.

@nate - any ideas?

I’d check for the presence of a NLP 2 plugin and trash it. Alternatively, you could re-run the v3 installer…

@Digitizer Thanks. No traces, (except back up v2 file now deleted). Deactivated v3. Downloaded v3 and reinstalled and activated the licence. Still same, the engine always reverts to v2.3 and have to go through the loop of rest and convert.

@nate - please chirp in when you get a chance.

Irritatingly odd. Let’s hope that @nate can do something about it.

Hi @lightglassimage

Hmm, I’m not able to replicate this behavior on my machine, but there could be a few things going on…

First, it could be that a previous setting from v2.x is causing this issue…

One way to test this be to reset your Lightroom Preferences, and then reinstall v3.0.2.

(In v2 of Negative Lab Pro, any “saved” default setting was stored inside Lightroom’s internal preferences, so it could have held onto that there.)

Second, it could be that the default preset has been modified.

If you have created a custom preset and use that as your default, or modified the previous default, it could be that when you saved the custom preset that your engine settings were on the older settings.

If that’s the case, you can try this: 1) Convert a new image, 2) Change the engine setting to v3+, 3) Then click the preset dropdown menu, and select “Update - NLP Standard”

Let me know if either of these work out for you!


1 Like

Hi @nate - Thanks so much. Reseting Lightroom Preferences/reinstalling worked.

I had to quickly scan few new negs to confirm as resting → converting again always set the engine to v3+. Newly imported negs instantly triggered engine v3.0.2

PS. just in case this happens to anyone else; resting LR preferences, removed ‘control N’ shortcut, so had to add it manually using ‘three spaces’ before Negative Lab Pro trick…

Thanks again All :face_exhaling:

@nate - Hi again,

I have just sent you an email. I am afraid I was wrong and actually did not work.

You also have an incoming WeTransfer with the screen recording to show it working (or not :frowning_face:)…

Thanks, Bobby

I’m having the same issue. I deleted the preferences and reinstalled 3.0.2 but I’m still getting v2.3 engine as the default. I tried this:

If that’s the case, you can try this: 1) Convert a new image, 2) Change the engine setting to v3+, 3) Then >>click the preset dropdown menu, and select “Update - NLP Standard”
for the NLP Standard - B+W preset but that didn’t resolve it either.
Eric Ghost

Thanks for the video.

Yes, I think I see what is going on…

I’ve been able to replicate the issue specifically within B+W mode.

I can get this patched in the next release. BUT, I would not expect to see a difference in black and white based on the difference in settings, since the differences in settings here are more related to color. The exception to this would be if you are doing a lot of toning on your black and white image.

@Eric - are you having issue with just black and white images? Or with color conversions as well?

1 Like

@nate - Thanks - now it makes sense why I originally confirmed that LR preferences reset worked. I quickly scanned few colour negs (previously not in LR library), so when imported, NLP triggered engine v3.0.2…

When will the patch be released? I pretty much only shoot B+W, home dev & scan (economic reasons :wink: :stuck_out_tongue_winking_eye:)

I have the same problem also with color conversions with NLP v3. I noticed that there are no Negative Lab V3 profiles available in Lightroom.

Hi Nate,
Thank you for getting back to me. I just tested several color conversions and the engine defaulted to v3.0+ so I don’t have the issue with color - only Black and White. Thanks much! NLP is a real game changer for me. I greatly appreciate your work!
Best regards,

Profile version numbers are independent of the version number of NLP. Different profile versions exist in order to support different versions of NLP. Think of profile version numbers as of generations rather than of numbers matching the NLP’s version.

1 Like

@nate - do you have an update when this will be fixed? Thanks!