Problem migrating to new computer - CryptUnprotectData


Upgrading to a new computer (images still on same NAS) incl re-installing LR CC Classic and moving all-plugins has resulted in the following error when trying to open NLP: “An internal error has occurred: There is something wrong in CryptUnprotectData”. Still Plug-In Managers claims the plug-in to be Enabled, hence does not seem to be a license problem.

Any suggestions, or is it a re-install of the plug-in that is required when migrating to a new computer?

Thanks in advance,


Any suggestions on how to migrate, or is the right way to go a fresh install?

I would recommend installing a fresh copy on the new computer. Just go into “file > plugin manager” and remove the current NLP plugin. Then follow regular instructions to install a fresh copy.

Ok, looks like whatever is happening here may be unrelated to NLP specifically and more related to LR’s publish manager… some other things to try (from Adobe):

You may also want to try to reset all your Lightroom preferences ( ) then reinstall the plugin from scratch.

(I see the notes about this error in Jeffrey Friedl’s blog, but it looks like he isn’t really sure why this could be happening, either)


The only option that solved the issue was to reset all preferences and re-install the plug-in.

However, now will see what happens when I re-install the rest of the plug-ins which worked perfectly in the past with NLP.



1 Like

Good to know, thanks Magnus!

Hi Nate,
about the Adobe-solution: where do I find the Publish Service plug-in?
Within the library module (LR 6.14) I only got the plug-in manager and there I find Negative Lab Pro among others but no Publish Service? Or do I have to look elsewhere?



The Adobe article is talking about this:

It could help if you, for instance, are using one of the publishing services (like Flickr). But if you have never set these up, that article probably won’t help.