V3 Issues & Fixes Thread

Hi friends,

All issues related to V3 launch should be posted here.

Please provide as much detail or explanation as possible, including:

  • Your operating system
  • Your version of Lightroom
  • Information about the scans you are working with (how they were digitized, if they were previously converted with older versions, etc)



“NLP only opens the first time, and then won’t open again”
I’ve heard a few reports of wacky behavior the first time using NLP v3. So far, this seems rare and seems to fix itself after either restarting the computer or after resetting Lightroom preferences. But if you experience issues with NLP not opening for you, please email me at nate@natephotographic.com

My license activation gets stuck on “Authorizing… Please Wait…”
If you try to activate your license and it gets stuck on “Authorizing… Please Wait…” then the issue is likely that you have entered the wrong license key. (It should be displaying a message that the license was not found, but there is a bug preventing that message from being displayed, which will be fixed in v3.0.3). Carefully copy and paste the license directly from the original email.

Common Questions & Fixes

“When I open NLP, I see a popup in the middles of my screen, and then it goes away and nothing else happens”
If you have multiple monitors set up, it is possible that the main NLP window is opening up in one of your secondary displays (even if that display is turned off). That is because NLP remembers where in your display it was last opened (relative to Lightroom).

"The conversion I made with a previous version are changing appearance when I go to the develop

If you find that your previous conversions are changing appearance WITHOUT even opening Negative Lab Pro, then the issue is that you were previously missing the camera or scanner RAW profile at the time you made the conversion. And now that v3 has added the correct profile, Lightroom is saying “Oh! Here is that profile I was looking for! Let me go ahead and apply it…” But now, there is a mismatch, because the conversion analysis is based on the default Lightroom profile (Adobe Standard), but the “Negative Lab v2.3” profile is now being applied.

You have a couple of options of how to fix this:

  1. Re-converting - Not only will reconverting fix this issue, but I would expect you to get much better results that you previously got when you reconvert (because the correct camera profile is now available). To re-convert, you can do the following: 1) Open the negative(s) in Negative Lab Pro, 2) Go to the “Convert” tab, and select “Reset Photos.” 3) Now hit the “Convert Negatives” button.
    This is the option I recommend, but understand that in some circumstances, you may need to just return the appearance of the photos.

  2. Restoring the Original Appearance of earlier conversions - If you’d prefer to restore the original appearance of the negatives, just select the photo in the develop module, and change the camera profile to “Adobe Standard.” You should see it return to it’s appearance before the upgrade. To do this on all your previous conversions in a few minutes do this: 1) In the Library Module, select “All Photographs” from the left pane under the "catalog’ section. 2) Make sure you Library filter is showing (if not, go to “Library > Enable Filters”). 3) Select the “metadata” filter tab, click on one of the filters, then in the lowest section, select “Image Status” as the filter. 4) In that filter, select “Converted.” 5) If you’ve made new conversions in v3, you can filter those out by selecting “NLP Version” in the next filter bar, and selecting just those images made with versions prior to v3. 6) Now that you have all your previous conversions selected, edit the first image to change the profile to Adobe Standard and confirm that it now appears correct. 7) Now select the rest of the images, and select “Sync Settings.” In the popup, make sure that ONLY the “Treatment and Profile” box is selected. After doing this, you should see all your previous conversions return to normal. However, please note that these images cannot be further edited in Negative Lab Pro, because it will attempt to update the profile back to the NLP profile. If you want to edit further in Negative Lab Pro, you could temporarily remove the Negative Lab Pro camera profiles, and the appearance and behavior will go back to before, but this would mean that future conversions will also have this issue and not be taking advantage of the NLP profiles.

UPGRADE: I can’t find the plugin after running the upgrade installer
If you can’t find Negative Lab Pro in the plugin manager (file > plugin manager) after running the upgrade, you may need to manually add the plugin. To do this go to “File > Plugin Manager” and click “Add”, then navigate to [Macintosh HD] / Library / Application Support / Adobe / Lightroom / Modules / for Macs or C: \ Users \ [username] \ AppData \ Roaming \ Adobe \ Lightroom \ Modules \ NegativeLabPro.lrplugin for Windows users, and add the plugin from there.

LICENSE: How do I activate the license?
After upgrading to v3, you will need to go to “file > plugin manager” in Lightroom and your new license key.

LICENSE: The “activate” button is greyed out and I can’t click it. What is happening?
This is because you are trying to use an old key from the previous version of NLP with the old format. NLP will not allow you to submit the old key. You need to use the new keys for v3.

LICENSE: It says it can’t connect to the internet. What should I do?
Make sure any firewalls or VPNs are turned off. Also make sure to disable any programs that might block the ability of Lightroom to connect to the internet (LittleSnitch, Radio Silence, PieHole, Lulu, etc).

LICENSE: Lightroom keeps dropping my license
This should be rare, but if you have installed software that is changing the MAC address of your computer (like Hyper-V Virtual Network Adapter), the software will prevent the NLP license from working, so you must turn this software off.



V3.0.2 fixes the following issues:

  • Undo History not resetting properly between uses - There was an issue with undo history being impacted by prior sessions. This has been fixed.
  • LR versions prior to 8.5 not loading - There was an issue with the NLP module not loading in versions prior to LrC 8.5. This has been fixed.
  • Default preset not applying correctly. During new conversions, the any custom default presets were not being properly applied. This has been fixed.
  • Narrow dropdown menus in Windows 11 - The Windows 11 UI had barely visible dropdown menus.

V3.0.1 fixes the following issues:

  • Irregular brightness opening single images after preforming a roll conversion - There was an issue with the cache not reseting properly after doing a roll conversion, causing subsequent single image edits to be off. This has been fixed.

  • Issue with NLP not finishing conversions under certain circumstances. If custom user presets were set to be the default preset, in some circumstances, NLP would not load new conversions. This has been fixed.

  • Issue with NLP not showing up in Plugin Manager after installation on some Mac systems - in some cases, NLP would not appear in the Plugin Manager after installation. This should be fixed, but if you find this happens to you, please go to “File > Plugin Manager” and click “Add”, then navigate to [Macintosh HD] / Library / Application Support / Adobe / Lightroom / Modules / and add the plugin from there.


Hey, For me the Installer doesn’t work. I use ventura and i placed the installer into the Apps ordner as per the instructions but it doesn’t install the Plugin. I already tried reinstalling Lightroom, locating the .lrplugin file manually and several Restarts.


Try this after running the v3 installer:

  1. Go to “file > plugin manager”
  2. Click the “Add” button
  3. Navigate to [Macintosh HD] / Library / Application Support / Adobe / Lightroom / Modules / NegativeLabPro.lrplugin
  4. Is the NegativeLabPro.lrplugin file there? If so, add it. If not, continue to 2 below.

For some reason, it seems that Lightroom isn’t recognizing the plugin even though it is in a location that it should be sourcing from that folder automatically.

I’m trying to replicate on my end to see if I can figure out why this is happening.


Hi @nate, Just installed V3 and it will pull up the window to convert, say it is converting the negatives, but then the control window will not pull up and the image does not actually convert. I’d appreciate any help you can give. I’m using a Mc M1 w/ Monterey (12.3.1) and Lightroom 12.4. Thanks! - Matt

1 Like

I think I got it fixed… I reset the preferences in Lightroom and reimported the negatives like you recommended here and it has been working for the last dozen or so negatives I’ve edited.

Thanks @mlim18 - if you find that this happens on just some existing negatives (and not on freshly imported negatives), there might be something with the metadata of those images that is throwing things off… it would be really helpful if you could do the following:

  1. Select some images that are not converting when you try
  2. Go to File > Export As Catalog in Lightroom
  3. Make sure that “Export Negative Files” is checked
  4. Send that catalog to me at nate@natephotographic.com (using WeTransfer, Dropbox, etc)


Will do. Thx Nate. In other news, I’m running into an issue where NLP is darkening photos upon opening after I’ve already converted and edited them. Any ideas on what could be going on here?

@mlim18 - I just pm’d you a solution to try.

UPDATE: The solution worked and is included in v3.0.1

Hi @nate, when changing the settings and selecting one from the “Negative Lab Pro” list, it is not possible to go back to the “Custom” one as it disappears. Is that by design?

Yes, “custom” in this case is just a placeholder for not having any preset as a base. I think you will only see it when working with conversions made in prior versions.

BUT, it should always be possible to go back to the whatever settings you had prior to changing the preset, using the new UNDO feature.

Thanks for the clarification. FYI if I will switch from “Custom” to a preset, then use the undo button it will not take me back to the previous settings I had with the “Custom” one. It will load another preset (I guess from the ones I’ve iterated before) If this sounds new to you or can’t reproduce let me know and I’ll provide you more info. Cheers

Hey Nate. Creating a new Preset doesn’t actually save it. It is gone the moment I close the NLP window and also doesn’t appear in the preset folder on my hard drive (macOS Ventura).

Hey team,

Ventura 13.4.1
LR Classic 12.4
Scans made with a Sony A7RIV. All freshly captured and imported this morning.

The presets aren’t holding my ToneProfile or WB preferences within a preset from roll to roll.
I can set a tone profile, say, “Cinematic Rich”
Then set a WB, like “Kodak” and then update my preset
Then set that preset as the default
but the next roll it will have reset the Tone Profile and WB back to defaults (TP: Linear-Gamma and WB:NONE)

Hi @egla - can you confirm that you are hitting the “apply” button? Any presets (or rolls) that you create will only be saved after you hit the apply button. So for instance, if you hit the “cancel” button to cancel out any edits that you made, it will not save your presets.

Thanks Matt, I can replicate the issue. Fix coming shortly.

UPDATE: Solved as of v3.0.2

1 Like

Oh thanks, that solves my issue. Just feels really counter-intuitive in my opinion as I have to manually select the preset on the first roll of creating a preset

Windows 11
LR 6.14
Vuescan .DNG, Imacon .TIF
NLP not coming up in Light Room

Hi Nate-
I’ll put this here as it has only been happening since I upgraded to v3.0.1.

If I go to Plugin Extras and click on Negative Lab Pro, there is no response at all, not even a flash.
If I click CTL-ALT-N a white rectangle and a faint outline flash for an instant on the left side of the LR window, and then nothing. This indicates that the shortcut is working, but NLP still isn’t interested.

I’m working with just one image.
NLP comes up properly with v2.4.2

Thanks for any perspective you can give me on this.

Roger Ide

I am having a similar issue to rogeride. My specs are:
Windows 11
LR 7.1
Trying to convert .ARW images.

The shortcut doesn’t work, and clicking on File-> Plug-in Extras → Negative Lab Pro doesn’t either.

I am guessing it’s due to the fact that we are running a relatively old version of Lightroom.

Any help in this matter would be greatly appreciated.

NLP 3.1 bad installer? It installs V2’s application which lacks all of v3’s features and UI. Also V3 is ghosted in the plugin menu. The app says v3.0.1 but it’s basically v2. I removed all modules, uninstalled LrC reinstalled same issue. I simply have a v2 instillation that says v3.

Running windows 10

And no way to upload photos here to show you the problem.

Hitting “undo” should always take you back to the previous settings. If you’ve iterated through multiple presets or made multiple settings changes, you will need to hit “undo” multiple times until you are back to where everything was initially. If that isn’t happening as expected, it would be great if you could share a video of what you are experiencing to nate@natephotographic.com

Not sure what you mean by this… the preset does not have to be selected to save. You can create a preset, and then select a different one in a session. As long as you hit “apply” it will save. When you hit “cancel” it will revert everything back to as if you had never opened NLP.

Hmm… Ok, it could be a couple things going on…

Can you try a few solutions and see if one of these work?

Resetting Lightroom Preferences

  1. Try resetting your Lightroom Preferences following these instructions: https://www.lightroomqueen.com/how-do-i-reset-lightrooms-preferences/

  2. When you relaunch Lightroom, go to “File > Plugin Manager” - if you don’t see the Negative Lab Pro v3 plugin there, go to “add” and navigate to “[Macintosh HD] / Library / Application Support / Adobe / Lightroom / Modules /” and add the NegativeLabPro3.lrplugin file from there.

Then see if it opens as it should, or if the problem still persists.

I think you may be mistaken. The screenshot you posted on Facebook showed that you have v3 installed and it is showing the correct UI for v3 (at least for the “convert” tab when you have one image selected).

Please note that you will not see the “convert as roll” option on the convert menu unless you have multiple images selected at once (because the “convert as roll” option only makes sense in the context of converting multiple images at once).

If you want to create a roll analysis for a group of already converted images, you will want to select all of them, then go to the Roll Tab and select “create new roll”