Version 2.3 and Lightroom Classic v11 won't start, Win 10 Home

I can’t seem to get my Lightroom Classic v11 to start. I click on it and just nothing happens. Last thing i did was updating NLP to version 2.3.

I’ve tried everything i could find on Adobe help, from killing task, deleting the lock file and restarting, to logging out and in, to starting LRC with reset settings, and still the same. Every time i start LRC, the *.lrcat-shm and *.lrcat-wal files are changing in the folder, but nothing more happens. I’ve even tried un-installing LRC and re-installing, without wiping out the profiles and user settings, and still same.

To complicate things, i remember recently previously updating to LRC version 11, so not 100% sure if that contributed. I’m pretty sure, i checked that worked before updating NLP v2.3, but now i can’t be sure.

Any ideas, short of uninstalling LRC completely, and redoing everything from scratch?



  1. The first thing I would try in a situation like this is to reset your Lightroom Preferences. This essentially completely removes the Negative Lab Pro plugin from loading as Lightroom loads. So if you’ve done this and it is still not loading, I would say that this is not related to the plugin.

  2. The only exception I can think of to point 1 would be if you happened to place the NegativeLabPro.lrplugin in a weird system folder, or a folder involved in Lightroom itself. So it would be helpful to know where you placed the NegativeLabPro.lrplugin file, and to try deleting it to see if that fixes anything.

  3. Beyond that, the next thing I would try is downgrading to LR Classic v10.4. You can downgrade via the Adobe Creative Cloud app. Just click the “…” on the right side of the app name and select “Other Versions” to find versions you can downgrade to.

Unfortunately, none of the above worked, including downgrading back to LRC 10.4.
I finally removed my LR catalog and at least the program starts, and I was able to recover an old catalog backup. I must of corrupted the catalog somewhere in one of the update processes…

Anyways, right now, i’m back up partially on LRC 11.0, with one week old catalog, but need to add back the NLP 2.3. I didn’t see NLP in the “Plug in extras” as before… so little more work… i hope. At least I now see the light at end of tunnel.


OK. Added back NLP in the Lightroom Plug-in Manager options and re-entered the license, and everything is good now. NLP 2.3 and LRC v11.0 working together.