Installation issue - Mac Sonoma

MacBook Pro M1
Lightroom CC 13.0.1
Mac Ventura 14.1.1
Downloaded the installation file for Negative Pro 3.2 for Mac. Installation routine ran as it normally does
Negative Lab Pro plugin not showing up in the Lightroom plugin list; Negative Lap Pro application not showing up in Finder/Applications
Moved the installation file to Applications & tried again - same result.


1 Like

Sonoma (as mentioned in the headline) or Ventura (as in the post)?

NLP is a plug-in for Lightroom and should be stored in Lightroom’s module folder.
It does not show in /Applications.

If the plugin is actually present, you need to restart Lightroom to add NLP to the module manager.
On my Mac, NLP is here:

Alternatively, it can be found in your user account’s Library folder.

Oops - Sonoma, not Ventura. When I run te installation app for the plugin, the installation runs normally, but the plugin is not in the Library, or anywhere else on the computer. I checked Library/Application Support/Adobe/Lightroom, and then searched the whole library for it. Also searched the whole Library for all .plugin files and it’s not there. Or at least it’s not visible, even though I open the Library using Option+Go.

Same thing using Spotlight, searching for “.plugin” files.

When I try to add it through Lightroom CC/File/Plugin Manager, it’s not on the list of plugins. When I try to add it manually, there’s nowhere to go to find it, because the negativelabpro.lrplugin file does not exist, or at least it’s not available


Have you re-run the installer or searched for the install log? The latter should help you find the plugin. Also, check the Library folder in your home folder.

Still trying to solve an installation problem for negative Lab Pro 3.0.2. Some further info:

Lightroom Classic 13.0.1; Mac OS Sonoma 14.1.2; M1 Mac with Rosetta installed.

When I run the Negative Lab Pro installation package, it doesn’t give me an opportunity to select the destination for the install. When OK the user license, it goes ahead and completes the installation.

The software installation log shows that Negative Lab Pro was installed, but there’s no way to tell where it was installed. I’ve searched the entire hard drive for the Negative Lab Pro plugin-in. The plug-in does not show up in Library/Application Support/Adobe/Lightroom/Modules, and it’s not listed in Lightroom in File/Plugins.

The only thing I can find anywhere on my hard drive is a folder with the Negative Lab Pro presets — those are in Library/Application Support/Negative Lab Pro/Presets. There’s no plugin file in either of the two folders of presets.

Any other suggestions?

Get in touch with @nate ?

Yup - he’s working on it.

According to the NLP installer, you should be able to find things as shown in the following screen capture:
NLP Folder Locations


  • The plugin will not show as a folder, but with a plugin icon.
  • Items are installed in /Library/, not in /Users/(accountname)/Library/
  • The screen capture focuses on files. Other things are done with respective scripts (not shown)

Nate provided the answer – the plugin was in my Macintosh HD/Library, not in the user library, but I was blocked because I didn’t have permission to access the Modules folder. I changed the permissions for the Modules folder, and once I did that, I was able to use it immediately in Lightroom.

Thanks for your help.

Hi, I’m new to all this, I got Negative Lab Pro for Christmas and am unable to open it, even after following the troubleshooting tips. I’m a 2021 iMac with M1, Sonoma 14.2; Adobe Lightroom, V.7.12, Negative Pro 3.2. I also added Rosetta. I know I’ve downloaded NLP, as I can see it in my computer’s files. In Adobe Lightroom, I’m unable to open NLP by going to File → Plug In Extras → NLP because “plug in extras” isn’t an option for me. I created a shortcut “^B” (^N is already assigned on my iMac) to try to force open, and I DID add the 3 spaces before “Negative Lab Pro”, even using the suggestion of copying it from the notes app and pasting it to the App shortcut to ensure the spaces were added. I have quit/reopened Lightroom, even restarted the computer twice and I’m still unable to access NLP. My b&w negatives are successfully in Lightroom as TIF images, and no where do I see any options to work with or open Negative Lab Pro after selecting an image to edit. I’m on hour 4 now. I’m sure this is just user error.

I had a similar problem. Turned out the negativelabpro.plugin file was not where Lightroom could access it. It was not in [User}/Library/Application Support/Adobe/Lightroom/Modules/. Instead, it was in Macintosh HD/Library/Application Support/Adobe/Lightroom/Modules, I opened it from there and it linked up to Lightroom. Special thanks to, who I emailed for help. He told me where to look. He supports his product with great patience.

Note that I had to change the permission for the folder Macintosh HD/Library/Application Support/Adobe/Lightroom/Modules in order to access it. If you see the folder but can’t open it, right click on it, click on Get Info, and change permissions.

Thanks! Very insightful, but unfortunately this didn’t work after I “unlocked” it to change permissions. I’m not seeing a “Library” folder to open after [User]; I only see the library folder after opening my Mac HD folder. Hopefully @nate can help

Apple hides the folder by default. You can unhide it by selecting your home folder, pressing command-J and checking the appropriate box.

Hint: you can show/hide all hidden folders by pressing shift-command-period (.)

You said, “I opened it from there and it linked up to Lightroom.” What is “…it…?” I don’t see an app icon in the folder named Modules/NegativeLabProPro3.lrplugin. Which of those files did you double-click to open NLP?

I was referring to the file named NegativeLabPro.plugin, which was in the Library folder of my Mac hard drive. It should live in [Mac HD]/Library/Application Support/Adobe/Lightroom/Modules. My problem was that I needed to give myself permission to open the /Modules folder, and then I could see the plugin, and Lightroom could access it. I think if you have permission to see the file, Lightroom will also see it, but I am definitely not an expert - I’m just reporting my own frustrating experience getting the plugin to activate. (And the frustration was well worth it - it’s a really god app.).

From what I understand, the plug normally installs the User/Library folder. That folder (User/Library) is hidden when you open Finder on the Mac. But if you open Finder, hold the Option key and click on Go up at the very top of the screen, you’ll see the User/Library folder. Then look for User/Library/Application Support/Adobe/Lightroom/Modules. That’s where I finally fond the NegativeLabPro.plugin file.

This used to be the case with earlier versions of DPL.
On my Mac with macOS Monterey (not that this should matter imo), the path is as follows:

Access rights are as follows
Bildschirm 2023-12-29 um

Thanks for the screen shot providing path to the Modules folder in Library. As soon as I found the Modules folder I saw the red line and realized that the problem I had in getting NLP to work was a permissions issue with a Mac Studio with OS Sonoma 14.5 and Lightroom Classic 13.3.

I changed the permission of the Lightroom Module to Read and Write and now the NLP plugin appears in File Manager. Unfortunately I wasted a lot of time chasing the problem but at least now I can get back to what I need to do, process a bunch of collections with high resolution camera scans of my camera negative archive.