Installation issue with MAC

Hey, so I have issues installing NLP on my Mac, it wont open the installation window and takes me straight to the script. Anyone have this issue before? Kind of bummed I cant start using the program immediately

Welcome to the forum, Oscar.

Did the installer present a dialog asking for some kind of permission and did you grant that permission?
Have you run the installer several times? Restart your Mac?
Can you see the hotkey entry in your system settings? Are there 3 spaces before “Negative…”

Anyway, you could install all items manually if you’re into such things and in a hurry. The script shown in your screenshot tells you where things go and you can get all the necessary things from the installer.

Before you begin, quit Lightroom

  1. Ctrl-click on the installer icon
  2. Click on “show package content”
  3. Navigate to the “Resources” folder
  4. Copy necessary items to the respective folders as listed in the script window
    a) “NegativeLab Camera Profiles” and “Vuescan Profiles” → Location as shown in script
    b) “NLP Enhanced Settings” → Location as shown in script
    c) “NegativeLabPro.lrplugin” → Location as shown in the script or to
    /Users/OscarSegura/Library/Application Support/Adobe/Lightroom/Modules
  5. Create the hotkey entry so that it looks like shown above
  6. Follow the instructions given under “TO FINISH YOUR INSTALLATION”


That script is the installer. It has run correctly.

After running the installer, you need to add the plugin to the plugin manager in Lightroom (file > plugin manager).

Inside the plugin manager in Lightroom (file > Plugin Manager), when you go to add the plugin, you may need to navigate in the folders to where the installer placed the plugin file is placed in “{YourUserName}/Plugins/NegativeLabPro.lrplugin”. For example, in your case, that is “/Users/OscarSegura/Plugins.”

(The Lightroom plugin manager should launch into that folder by default when you go to add it, but on some systems, that isn’t happening… so you just need to navigate to where the plugin file was placed by the installer)

I would NOT advise following @Digitizer 's suggestion… not only could this create an issue where your Mac security system will stop it from running, but it will make upgrading in the future more difficult.


Agreed, manual installs will make upgrading more difficult. It’s good to stick to the standard whenever possible. Nevertheless, a manual install can help in cases where the installer does not (seem to) work.

I’ve had the same issue. I checked all the install spots and nothing was written. All the permission (Security and Admin) were approved. I restarted and tried running the installer a few times but still the script window comes up and nothing was accomplished.

What kind of Mac and macOS are you using?

MacBook Pro, mid 2015, MacOS 10.14.6

1 Like

It didnt add any sort of installer, Still working out the kinks but I really want to get this running, feeling bummed i got this and having failed installing it

Installing NLP can fail and I had to run the installer several times on my MacBook Air M1 (macOS Big Sur) before everything was in the right place…

Installation went fine on my 2019 iMac with macOS Mojave. Had to install it on each account separately though. NLP’s installer (and the plugin) does not support multiuser installations yet. That’s why I also tried manual installation, which worked fine. Caveat: @nate’s comment above.

I am running Yosemite right now, but maybe I can un-install NLP and re-install it from the download link sent to me? I am a noob when it comes to Mac. I tried doing it manually but looks like the way my folders are organized are different

Hi Nate!

I tried to attempt it, but I couldnt even get too far because I dont really know how to do some of this manual script launcher. Is there another way of getting NLP on my lightroom? The access code isnt working although I have disabled firewall. Is there a way to uninstall the plug-in?

Thanks for you help so far!

I tried it again, multiple times with no change in results. Script states it did certain actions but I see nothing actually done. I tried logging in my Admin acct. and ran the app. Script said it couldnt find things and added folders to Application Support. Checked and nothing there. Went back to my user acct. Exited from Pulse Secure, app for remoting into work, and again no change. I would do it manually but Nate suggested it as not the best route.

@GWTG, you seem to have a Mac with more than one user account. If this is the case, you need to run the NegativeLab installer on each account with which you want to use NLP.

When you install NLP with every user account, many things will be installed more than once. If this is not okay with you, you might want to try the manual installation despite Nate’s recommendation. If your bus is not taking you to the top of Mt. Everest, your feet might…

Hi, if the installer script is open, close it. Then run the installer again (just double click the installer app). Then go to “Finder > Go > Go to Folder”. Copy and paste this into there, minus the quotes: “~/Plugins” and hit “Go.” That should take you to the directory where the installer has added the plugin itself. You should see a file there named “NegativeLabPro.lrplugin”

Are you able to find the plugin it has added that way? You can also do a search in finder for “NegativeLabPro.lrplugin” to find it.

If you see the NegativeLabPro.lrplugin file this way, then you just need to open Lightroom 6 or Lightroom Classic and go to “File > Plugin Manager”, and then find and add the NegativeLabPro.lrplugin file from there.

If you don’t see the NegativeLabPro.lrplugin file where it should be, then something has failed with the installation.

You need to run the installer while being in the same user account that you have Lightroom set up on. Otherwise, it won’t be able to find the correct preferences folder where the camera profiles go.

You don’t need to know anything about the manual script launcher. Running the script just adds the files to correct directories, and adds some other things like the shortcut key. The first time you run the script it gives you specific directions of what to do next in Lightroom. After that, any remaining times you run the script it assumes you are just updating the plugin, so it doesn’t give any more directions (I’m changing this in the next installer so that it just always assumes that you are installing it for the first time and provides the remaining directions for adding the plugin in Lightroom).

After running the installer, you need to add the plugin itself to the plugin manager in Lightroom (file > plugin manager). You may need to navigate in the folders to where the installer placed the plugin file, which should be at “Users/{YourUserName}/Plugins/NegativeLabPro.lrplugin”

(It should place you in the right folder by default when you go to add it, but on some systems, that isn’t happening correctly… so you just need to navigate to where the plugin file was placed by the installer).

“The folder can’t be found.” I’m stumped.

SInce I was evaluating I went ahead and manually loaded the profiles I needed, the plugin and the NLP etc. It worked fine except there was no LUT table. I went ahead and loaded some negs I had trouble with getting the correct color. Overall I was pretty impressed. I had more scale to work with than simply inverting and using curves. One neg it was spot on, I couldnt get the skin-tones right on my own. I’m going ahead and purchasing and we will eventually figure out my installation issue.