The beta killed my NLP and I can't revive it

I thought I’d give the beta of NLP a go. Didn’t work for some reason so I decided to go back to the stable version. Can’t do that so I thought I’d try the beta again. Got further this time but it still doesn’t work for me.

My first problem seems to be I keep all my Lightroom plugins in a folder in my Pictures folder. (Mac user by the way.) That works for me but the NLP beta seems to want to be in ~/Plugins. NLP wont run when I move the plugin to ~/Pictures/where-my-plugins-live.

On reinstalling the stable version NLP won’t run because a database has been updated. I see on the FaceBook feed I don’t have the option to go back - if I was warned about that I didn’t see it!

I’ve now reinstalled the beta and left NLP where it defaults to! It opens on ctrl-n and I’ve reset some previously converted files. But trying to convert gets an error (screenshot attached).

Kinda stuck here so any advice welcome!

Screenshot 2020-07-23 at 16.36.31|430x351

Let us, for a moment, assume that all apps, that have been installed on a Mac, can be removed. This would mean that we can go back to an older version of an app (that runs on the present version of macOS and Lightroom) by removing the new app and then installing the old app. This should also be true for a Lightroom plug-in with the caveat that metadata, written by the new plug-in might not be readable by the old plug-in. This could mean that all the work (not the images themselves) you have done with the new plug-in will be lost. Speaking about a BETA plug-in, the amount of work should be relatively small and not concern relevant things - or we’ll have to discuss on how to test beta software on a prod machine… Read on (and do so until you reach the bottom), if the above sounds reasonable, if you can stomach some loss and if you assume responsibility for what you do. I give no guarantee that the procedure is complete and will work.

Caveat: Geek stuff ahead!

  • Make sure you have a working backup! If possible: make a clone or two!
  • NLP somehow remembers the registration key. I have no idea how and where and can give no hint if re-registering will work or not.
  • You might have to redo the keyboard shortcut as explained by Nate
  • If the Hot Steps below are too hot for your taste, you’ll have to wait for the new prod version of NLP - or test the procedure outlined below on another backup of your Mac.
  • Continue at your own risk.

Hot Step One - Clean up things in Lightroom

  • Remove from Lightroom (not the HD) the test images you’ve treated with BETA NLP
  • Open the Lr Module Manager and note where the BETA NLP plug-Ins are on your HD, then deactivate the BETA NLP plug-in
  • Tell Lightroom to optimise the catalog, wait until finished
  • Quit out of Lightroom

Hot Step Two - Clean up things in the Finder

  • Delete (or set aside) the NLP lens profiles, they can be found in
    Library/Application Support/Adobe/CameraRaw/
  • Delete (or set aside) the NLP plug-in, it can be found in
    Library/Application Support/Adobe/Lightroom/Modules/

Note that “Library” can be found in your home folder and your drive, next to the User, Applications and System folders. Check both places (I don’t know where beta nlp puts its things)

Step Three - Reinstall the prod version of NLP

  • Let the installer do its work

Please let us know it it worked.

OK, thanks for those tips. A couple of points, not criticism of your help but generalised.

but later

It would be useful to know that as, if a full removal is required we need to remove everything NLP has installed. Otherwise we cannot be sure a reinstallation will resolve whatever problem we’re trying to fix.

On to the fix…

How do I tell, how do I know which images I’ve used the beta on? I tried it on a few random images, usually where I had similars to see what, if any, differences there are. So among a few hundred images are scattered a few tens which were ‘touched’ by the beta. Perhaps the beta left its mark by - as suggested - changing some metadata. Can I search out these images using that metadata?


Okay, let’s see

Registration Key: If ever there is an issue after the procedure, Nate will probably be willing to help. After all, he wants his software to do its job with the customers.

Beta Treated Images: You can search for these images like so:

  • Search for the version number of the beta (find it in Lr’s Module Manager)
  • Check metadata to see if the version number is right, add keyword " ZOéOHç%&"
    (assuming that you haven’t used this keyword on any of your images)
  • Remove all images with the keyword ZOéOHç%&
  • Sync the folder(s) that contained these images

Beta Testing Lessons Learned (Updated)

  1. Create a test-user account
  2. Put a set of physical copies in the test-user’s image folder
  3. Create a separate Lr catalog for testing, specially if you skip Nr. 1.

What?! Why am I adding a nonsensical keyword?

These actually appear to be in the folder " NegativeLab Camera Profiles" at ~/Library/Application Support/Adobe/CameraRaw/CameraProfiles/ and I assume I need to remove that entire folder including the VueScan Profiles.

There’s no folder by that name there. However there is in ~/Library/Application Support/Adobe/Lightroom/Modules but that folder does not contain the NLP plugin.

OK,I see now, the Users’ library is generally referred to as ~/Library rather that /Library which is a different folder as I’m sure you know. Had me confused for a second.

That didn’t work then! Screenshot 2020-07-28 at 12.28.10

That message suggests LR contains metadata the plugin can’t read. I have - as directed - removed all the images touched by the beta and followed other instructions other than the odd keyword direction.

Still stuck then…

Adding a keyword that is not used otherwise because it makes no other sense than to find the images that have been treated with that ominous beta plugin. You could also use NLP_BETA or something that you don’t use otherwise.

OK, I actually wondered if some text had got mangled in your post!

Ok, easiest way to fix this is to revert to backup.

Cos everyone makes a backup before they install anything new. And if you don’t you should. TBH I’ve never had a bad experience trying new or beta software but this came close.

Beware. If you’re not sure how you’ll get out of it when it all goes wrong, stay two meters away,

Hi, from the error screenshot, it appears Lightroom is set to use the NLP that you have in the folder “Users/davidgorder/Pictures/Lightroom Catalogs…/Lightroom Plugins/”

If you have installed the beta in ~/Plugins (default), but you had previously customized NLP to have it in a different folder, you need to go into the Lightroom plugin manager (File > Plugin Manager) and remove the existing installation and add from the ~/Plugins folder.

Look in the main beta thread in Facebook - there is a link to deprecate to an archived version of 2.1.2 if that’s what you want to run… basically it is 2.1.2 but with the revised metadata definitions.

I’m pretty sure I had the plugin location sorted. But are you saying the 2.2 version plugin must stay where you install it? That’s not usually the case with plugins and I keep all of mine in a plugin folder of my choosing.

OK, the Facebook thread is long and winding so I obviously missed that. Meanwhile I’ve used a backup to get me where I was before.


OK - In your original post, you stated…

But looking at your error screen, it is clear that the plugin manager is using whatever version you have installed in the custom location (not the default).

But maybe I’ve misunderstood what you are saying.

It doesn’t necessarily have to stay in the folder that it is original installed, but moving it does complicate things. For one, moving the plugin to a custom location complicates the update process (as you’ve discovered). Also, unlike most plugins, Negative Lab Pro needs to be installed in a folder that has full read/write access so it can analyze the images. This is typically a bigger issue with Window users, but can also be an issue for Mac users. Keeping it in the ~/Plugins folder (and having your plugin-manager pointed to the version in this folder) is the simplest, safest way to run it and makes upgrading easier.

No, sorry, I wasn’t being clear enough. I was trying to say I had a second attempt at installing and on that occasion left the plugin where the installer installed it. The screenshot would have been from my first attempt.

The screenshot has a clue about not having the plugin in the correct location but isn’t of use to Mac users (and, as you suggest, permissions aren’t usually a problem for us).

My trouble is assuming - based on my experiences - LR plugins follow a set way of working. I have lots of plugins. Most were ‘installed’ by dropping the plugin into where ever I want to keep it and pointing the Plug-in Manager at its location. No ‘install’ process. Then these plugins are updated by clicking an ‘update’ button in the Plug-in Manager.

And then, naturally, I may not have read or understood all of the Read Me. And, to be fair some of that could be better written. The parts about the ‘Unknown Developer’ warning don’t reflect the usual way of getting around this issue. (Its done by opening System Preferences’ Security & Privacy and allowing the install to take place.)

Its a beta so take my comments as feedback and observations of how people may upgrade. I’m not meaning to have a go at you.