V2.2.0 on macOS: could not locate LUTs

Hi, I’ve confirmed the installation was successful and the plugin version is 2.2.0. I’m running LrC 9.4 on macOS Big Sur public beta 9 (sorry, hope that isn’t the cause). No LUTs are available. All I see is this:

Any pointers on troubleshooting this? Thank you!

Hello! I’m having the same issue on macOS Mojave 10.14.6 with LrC 9.4.


If you see this message, it means that the enhanced presets for the LUTs weren’t added where Lightroom expects them (or never got added). This could happen if you have your presets set to be stored with your catalog instead of globally. Or in Windows, this is a step you have to do manually.

Here is what you need to do:


  1. In Mac Finder, right-click on the NegativeLabPro-OSX-2.2.0 app in your unzipped download, and click “show package contents”
  2. Navigate to “Contents > Resources”
  3. Make a copy of the folder “NLP Enhanced Settings” and move it somewhere you can access.
  4. Open Lightroom and go to the “Develop” module
  5. Go to “file > import develop profiles and presets”
  6. Navigate to where you moved the “NLP Enhanced Settings” folder. Then select ALL of the items within that folder, and add them


  1. Open Lightroom and go to the “Develop” module
  2. Go to “file > import develop profiles and presets”
  3. Navigate to your unzipped Negative Lab Pro download, and go to the “NLP Enhanced Settings” folder. Then select ALL of the items within that folder, and add them.

Now when you open Negative Lab Pro, it should show the LUTs.


1 Like

Thank you! That worked perfectly!

I use different accounts on my Mac for installation, normal use and testing.

These are the folders into which I put the profiles and the settings folders:

The plugin needs to go into (each) user folder, I put it here:

As of today, the plugin does not work if installed here:

X-Rite’s Color Checker plugin works in this place, but the NLP plugin seems to want/need user rights.

Thanks Nate. Instead of manually locating and moving the LUT presets I just turned off “store presents with catalog” and restarted LR. Now NLP finds the previously-installed LUTs just fine and I confirmed my existing presets moved back to their default location. Appreciate the help.

I did it this way because I worry about future NLP updates changing the LUT presets. Any user who went through this manual LUT installation method will miss out on those future changes unless they go through this process each time. No thanks. :wink:

1 Like

Mac Catalina 10.15.7 with latest Lightroom CC. I had stored presets with the Catalog, but (based on discussion above), switched back to default locations.
I followed the procedure you described above using the “Import…” and selecting all the items in the NLP Enhanced Settings folder. But the LUTs do not sow up in LR CC: just below the WB settings Temp/Tint sliders, I am told “Could not locate LUTs”. But when I follow your procedure, LR says it is importing but then finishes with the notice “Unable to import profiles and presets - All items are already imported”. But, even after quitting LR and restarting, I am still told “Could not locate LUTs”
The NLP Enhanced Settings folder is in the Library->Applications->Adobe->Camera Raw->Settings folder, which is where I think it needs to be (Adobe stores “stuff” all over the place).

Any suggestions would be appreciated.

Update- following a suggestion online about how to load LUTs into LR, I opened a raw image in PS, and I find that Camera Raw in PS includes the LUTs in the folder “NLP Enhanced Settings” in the CR Presets list along with the regular Develop Presets (which do show up in LR)… But the NLP Enhanced Settings don’t show up in LR. (at least according to the NLP message). Presets in LR are NOT stored with Catalog. Don’t PS and LR supposedly both access them thru CR?

Hello! I’m having this problem too. I’ve tried the above fix, but they’re still not showing up…

Anybody??? This problem still exists

Hi @SWRick

Hmm, a few things that may help diagnose this issue:

  1. When you are in the Develop module in Lightroom, on the left hand pane, expand the “Presets” section and look for a preset folder called “NLP Enhanced Settings”. It should look something like below. Can you confirm if this is present or not?

  2. Do you get any kind of “missing profile” warning when you first open a file with Negative Lab Pro? The warning would be in Lightroom just below the profile section.

  3. What kind of file are you working with in NLP? Is it a Camera Raw, a Vuescan/Silverfast RAW, or Tiff?


  1. Something like that is present, but slightly different header. Also, they are all grayed out and in italics. See screenshot below.

  2. Yes, Missing Profile warning

  3. RAW File- Nikon Z7 NEF

Rick Fee

I see different folder names in the two screenshots (yours and Nates)… NLP might look for a specific folder name though. :fire_extinguisher:

Ahh, then this is the root of the problem… if you can fix this problem, then it should work.

When you ran the installer for Mac, if should have added the “NegativeLab Camera Profiles” folder to your CameraProfiles directory. Inside there, there should be a file called “Negative Lab - NIKON Z 7 v2” which would be the correct profile for this camera.


as you can see below, that profile is in what I think is the proper location:

Does it matter that there is a very similar profile without the “v2”? I didn’t delete it in case it belongs there.


Hmm :thinking:

That is very odd… if the profile is there, then it should be able to find the profile for your Z7 (unless you are using a Z7 ii by chance?)…

What was the process for the NEF files? I’m assuming you just imported into Lightroom in the normal way (i.e. you didn’t process with any other software beforehand?).

I also assume you’ve tried restarting Lightroom after installing Negative Lab Pro?

Feel free to email me a sample NEF file at nate@natephotographic.com and I can see if it gives me the same trouble.

Does anyone have an update or a fix? I am still having this issue with my Nikon Z6ii

Hi, there weren’t profiles available yet for the Z6ii when v2.2 came out… they will be included in the v2.3 package, but in the meantime, you can download and manually add the Z6 ii profiles from this folder:

thank you! I think I loaded them properly and Lightroom seems to still not locate the LUTS

Hi, to make sure the base camera profiles are properly loaded, you can do the following:

Open up the Profile Browser by clicking the four-square icon to the right of the currently selected profile.

Screen Shot 2021-03-19 at 12.40.57 PM

Select “List” then scroll down and expand “Profiles”. You should see “Negative Lab v2.0” profile option.

If you see that profile available, then your base camera profiles are correctly loaded. If you don’t see that available, then they are not properly loaded.

Next, you can check to make sure your enhanced profiles are properly loaded.

In the Develop section, on the left panel, expand the “Presets” tab if it is not already expanded. You should see a section called "NLP Enhanced Settings"

If this is not present, then you need to go back and load the enhanced settings (this should be done automatically on Mac, but you must do it manually on Windows).

If everything appears to be present as it should be, but you are still not able to get the enhanced profiles, make sure that:

  1. You are on a newer version of Lightroom Classic
  2. You are using a color-based Color Model (such as Frontier, Noritsu or Basic). The profiles will not apply to the “None” color model selection, or the B+W color model.

Hope that helps!